Data Infrastructure Management Software Discussions


Problem importing workflow

Hi, I've 2 instance of WFA (one in test environment with a test dfm and simulators and one with a real filer). I was importing some workflow from the test machine to the second machine and I get an error that say: failed to unmashal provided data.

The 2 instances was upgraded to the latest 1.0.2 version some days ago and before this error I was able to import another workflow coming from the same server.

Into the server logs i get this entry:

2012-01-27 18:44:15,229 CET ERROR [org.jboss.aspects.tx.TxPolicy] (http- javax.ejb.EJBTransactionRolledbackException: Failed to unmarshal DictionaryEntry_0f487859_bd26_4a22_8ffc_8f44eb5b92b1.xml (in process jar entries [DictionaryEntry_0f487859_bd26_4a22_8ffc_8f44eb5b92b1.xml, CommandDefinition_e14b4b56_3d15_469b_8fb8_801809d28db1.xml, TabularWorkflow_a05c1d83_c0b8_4d53_8631_8138aef7d41d.xml, DictionaryEntryFilters_c582fbae_8186_4eb6_9fca_ef9b34c8bc11.xml, Filter_fe43ecc0_174c_416b_8903_c248256516e8.xml, CommandDefinition_71aee522_55dd_4956_81dd_0aad32f16f43.xml, DictionaryEntry_466dd30c_022f_4727_a1d2_d6c6524d5622.xml, DictionaryEntry_2ccb2fbd_9dd9_45ad_97b5_9d65c8c92026.xml])

That file is the VSM Dictionary entry and is the standard one containing:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<dictionaryEntry type="VSM" stringRepresentation=" + &quot;:&quot; +">




    <description>Dictionary entry for VSM (Volume SnapMirror) relationship object</description>


        <object-attribute type="String" naturalKey="false" name="destination_interface">

            <description>The destination interface to use for mirroring traffic (i.e. hostname-bkup, hostname-e4d)</description>


        <object-attribute type="String" naturalKey="false" name="schedule">

            <description>The schedule to be used for the VSM (i.e. '* 23 * *' )</description>


        <object-attribute type="String" naturalKey="false" name="source_interface">

            <description>The source interface to use for mirroring traffic (i.e. hostname-bkup, hostname-e4d)</description>




        <object-reference refCol="secondary_volume_id" naturalKey="true" name="secondary_volume">

            <description>The name of the secondary volume to be used for the VSM relationship</description>



        <object-reference refCol="volume_id" naturalKey="true" name="volume">

            <description>The name of the primary volume to be used for the VSM relationship</description>






Re: Problem importing workflow

Hi Francesco,

I ran into this last week - there is a bug in 1.0.2 that can cause such an issue.

The good news is it appears to be fixed in 1.1 but until that it available you will need to either export/import the workflow in pieces (Filter ,Finder ,Workflow) or just use restore if possible  (I did the latter and it worked fine)

Sure the other chaps will chime in if they have any better suggestions




Re: Problem importing workflow

My problem is that it will get the error importing the workflow (when it's exported I think that in the .dar file there are also all the prerequisite and those are the ones generating the errors).

I've tried to remove all but the workflow from the dar file but I get the same error.


Re: Problem importing workflow

Yes - I ended up backing up and restoring the database to get around it;


Re: Problem importing workflow

Probably for me it will be faster to manually recreate those 3 workflow because on the production system I already have defined new workflows that are not in the test system (I'm missing a vcenter/esx in the test env).

Try the NEW Knowledgebase!
NetApp KB Site