Data Infrastructure Management Software Discussions

Highlighted

Resize Volume command in WFA completes successfully, but Volume size is not increased

I'm trying to increase a FlexVol using the Resize Volume command in WFA. I just want to increase the size of the volume by an amount that will be input by the user. What do I enter for the AutoSizeIncrementSize parameter? I tried using $Size. The command completes successfully, but the volume doesn't get increased. 

6 REPLIES 6
Highlighted

Re: Resize Volume command in WFA completes successfully, but Volume size is not increased

I just realized I think I should be using the 'TargetSize' parameter. I am able to put a final size of the volume successfully, but I want to increase the volume size by a user input amount. I tried using volume1.size_mb + $Size, but I get error:

Illegal expression: volume1.size_mb + $Size
Location: 'Resize volume' command > 'Other Parameters' tab > 'TargetSize' property

 

Anyone know the syntax here?

Highlighted

Re: Resize Volume command in WFA completes successfully, but Volume size is not increased

Hi Campbell,

Thanks for the details.

 

For creating customized workflow for Resize volume please follow the below steps:

 

1. Search and define should be done for volume dictionary.

2. For TargetSize Instance, MVEL expression as mentioned here: ((int)volume2.size_mb ) + $TargetSize (Attached is the screenshot for reference)

3. Resize volume command, TargetSize should be provided in MB(if one GB need to increased please provide as 1024)

 

For more details please let us know, we will have WebEx disucussion.

 

Best Regards,

Shiva

https://netapp-meeting.webex.com/join/ssivakum

 

 

 

View solution in original post

Highlighted

Re: Resize Volume command in WFA completes successfully, but Volume size is not increased

I am still getting the illegal expression error. See attached screenshots. I believe my volume selection should be working fine because if I have user input only as final target size, I'm able to resize the volume successfully. But, seems to be failing on illegal expression with ((int)volume2.size_mb ) . Thanks for the assistance, I can do a webex if you like.

resize_vol_error1.jpgresize_vol_error2.jpgresize_vol_error3.jpg

Highlighted

Re: Resize Volume command in WFA completes successfully, but Volume size is not increased

Thanks for the details.

 

In workflow, Please change Parameter type from string to Number for TargetSize parameter.

 

If still problem exists, we will have webex on tomorrow(March 06) 7 P.M. IST.

Please confirm your availability for the Webex.

https://netapp-meeting.webex.com/join/ssivakum

 

Thanks,

Shiva

Highlighted

Re: Resize Volume command in WFA completes successfully, but Volume size is not increased

I changed the TargetSize parameter from string to Number and still getting illegal expression. Yes, I will be there for the WebEx on March 06 7 P.M. IST

 

Thank you

Highlighted

Re: Resize Volume command in WFA completes successfully, but Volume size is not increased

The solution above resolved the issues. The reason I continued to get the error initially is because I wasn't following the first item in the instruction, using 'search or define' to define the volume being resized. Once I fixed that by adding the command shown here, everything worked perfectly.

 

resize_vol_error4.jpg

Check out the KB!
Knowledge Base
All Community Forums