Data Infrastructure Management Software Discussions

Highlighted

Setting up NetApp Harvest

I'm currently trying to setup Grafana to monitor our NetApp's.  I have followed the two guides provided by NetApp and currently have Grafana, Graphite & NetApp Harvest running on a ubuntu 16.04 LTS VM.

 

Everything appears to test ok & I can connect to the web portals for both Grafana & Graphite fine.  For some reason though NetApp Harvest dosn't appear to be pulling data from my SAN.  I think I've configered it correctly but when I run the command ./netapp-manager -status I get the following out put: -

 

root@stu-netmon-001:/opt/netapp-harvest# ./netapp-manager -status
STATUS POLLER GROUP
############### #################### ##################

 

 

I've included a copy of my config file, I'm not sure why the 2 fillers arn't listed here but I think thats my problem.

 

Many Thanks for any gudiance.

3 REPLIES 3
Highlighted

Re: Setting up NetApp Harvest

Hi @IanPMcCue

 

Sorry to hear it's not working.  Normally you cluster would be listed in the output you pasted so there must be an issue with your netapp-harvest.conf file.  You mentioned it was attached but I don't see it.  Can you provide the contents?  You can also just paste with inlne, use the {i} icon in the editor and it will be formatted nicely too.

 

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

 

Highlighted

Re: Setting up NetApp Harvest

Hi Sorry, though I had added the file.  Here is the config file: -

 

##
## Configuration file for NetApp Harvest
##
## This file is organized into multiple sections, each with a [] header
##
## There are two reserved section names:
##  [global]  - Global key/value pairs for installation
##  [default] - Any key/value pairs specified here will be the default
##              value for a poller should it not be listed in a poller section.
##
## Any other section names are for your own pollers:
##  [cluster-name]     - cDOT cluster (match name from cluster CLI prompt)
##  [7-mode-node-name] - 7-mode node name (match name from 7-mode CLI prompt)
##  [OCUM-hostname]    - OCUM server hostname (match hostname set to system)

## Quick Start Instructions:
## 1. Edit the [global] and [default] sections and replace values in all 
##    capital letters to match your installation details
## 2. For each system to monitor add a section header and  populate with
##    key/value parameters for it.
## 3. Start all pollers that are not running: /opt/netapp-harvest/netapp-manager start
##
## Note: Full instructions and list of all available key/value pairs is found in the
##       NetApp Harvest Administration Guide

##
#### Global section for installation wide settings
##
[global]
grafana_api_key   = HIDDEN BY ME
grafana_url       = http://localhost:9090

##
#### Default section to set defaults for any user created poller section
##
[default]
graphite_server   = HIDDEN BY ME
username          = netapp-harvest
password          = HIDDEN BY ME

## If using ssl_cert (and not password auth) 
## uncomment and populate next three lines
# auth_type         = ssl_cert
# ssl_cert          = INSERT_PEM_FILE_NAME_HERE
# ssl_key           = INSERT_KEY_FILE_NAME_HERE

##
#### Poller sections; Add one section for each cDOT cluster, 7-mode node, or OCUM server
#### If any keys are different from those in default duplicate them in the poller section to override.
##

# [INSERT_CLUSTER_OR_CONTROLLER_NAME_HERE_EXACTLY_AS_SHOWN_FROM_CLI_PROMPT]
hostname       = HIDDEN BY ME
group          = HS1

hostname       = HIDDEN BY ME
group	       = HS1

# [INSERT_OCUM_SERVER_NAME_HERE]
hostname          = HIDDEN BY ME
group             = HS1
host_type         = OCUM                  
data_update_freq  = 900 
normalized_xfer   = gb_per_sec  

 

Highlighted

Re: Setting up NetApp Harvest

Hi,

 

Kind of late reply but maybe it helps others.

 

In the pollers section, you need to remove the hash and insert the hostname into the square brackets.

 

[Hostname1]
hostname       = HIDDEN BY ME
group          = HS1

[Hostname2]
hostname       = HIDDEN BY ME
group	       = HS1

[Hostname3]
hostname          = HIDDEN BY ME
group             = HS1
host_type         = OCUM                  
data_update_freq  = 900 
normalized_xfer   = gb_per_sec  

 

Try the NEW Support Site!
NetApp Support Site
Forums