Data Infrastructure Management Software Discussions

Slow workflow execution with WFA 4.2

Hi,

 

We encounter slow workflow execution on our new WFA server (WFA 4.2 RC1).

 

The Create Volume command took 36219 milliseconds (>35 secs)  to complete. I am using a local user account with CRL (Certificate Revocation List) 

 

 

On the old WFA server (WFA 4.1), same command took 10344 milliseconds (>10 secs) to complete.

 

 Any suggestions appreciate.

 

Thanks,

Henk Snel

 

 

13 REPLIES 13

Re: Slow workflow execution with WFA 4.2

 

 

I meant to say that CRL is disabled for local user.

Re: Slow workflow execution with WFA 4.2

We noticed the same thing as well when we were testing out 4.2RC1.  We then tried to start the services with a domain user and it went super fast.

 

Can you test out that scenario as well to confirm?

 

 

Re: Slow workflow execution with WFA 4.2

Re: Slow workflow execution with WFA 4.2

^

Got 404 on the link

Re: Slow workflow execution with WFA 4.2

Re: Slow workflow execution with WFA 4.2

we have started the services under a domain user. The workflow execution is still very slow.....

Re: Slow workflow execution with WFA 4.2

Hi Henk Snel,

 

Please provide your machine configuration.

So that we will try to reproduce it locally

 

Regards,

Sundar

Re: Slow workflow execution with WFA 4.2

Hi Sundar,

 

 

This is the machine configuration:

 

CPU: Dual 2.50 Ghz Intel Xeon

Memory: 8092MB

OS version: Windows 2012 R2

System Type: Server (VMguest)

 

Thanks,

Henk Snel

 

Re: Slow workflow execution with WFA 4.2

Hi Sundar,

 

I've found the problem.

 

The problem is the slow loading of Powershell DataONTAp module within WFA. Which is 4.3.0.

 

I've replaced that version by 4.2.0 (which comes with WFA 4.1).

 

The volume create command now takes 10 secs to complete in stead of 40 secs.

Re: Slow workflow execution with WFA 4.2

Thanks 

 

 

Re: Slow workflow execution with WFA 4.2

WFA 4.2 (GA) has been released.

 

The workflow execution is still terrible slow with DataONTAp 4.5.0 vs DataONTAP 4.4.0.

 

For example:

 

The creation of a vserver takes more than 40 secs with DataONTAP 4.5.0. Whereas with DataONTAP 4.4.0 it takes approx 8 secs.

 

Re: Slow workflow execution with WFA 4.2

Problem solved.

 

 

I’ve executed the following test scenario:

 

  1. Disabled proxy for Local system account
  2. Disabled CRL checking for Local system account
  3. Disable Automatically detect settings for Local system account
  4. Reboot de server
  5. Executed workflow for create basic Cluster Data ONTAP volume
  6. The creation of the volume takes 27 secs to complete
  7. Enabled proxy for Local system account
  8. Reboot the server
  9. Executed again workflow for create basic Cluster Data ONTAP volume
  10. The creation of the volume takes > 5 secs to complete

 

 

This test was executed with WFA 4.2 and DataONTAP toolkit 4.5.0.

 

 

View solution in original post

Re: Slow workflow execution with WFA 4.2

@HenkJ_Snel 

Can you please post more detail for what you mean by / did for steps 1, 2, 3, & 7?

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public