Data Infrastructure Management Software Discussions

Highlighted

Re: Slow workflow execution

Regarding my case engineering opened a new bug for this issue.

http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=802749


Highlighted

Re: Slow workflow execution

Francois,

What exactly did you change within your server to get the workflow to speed up? Are you talking Internet settings (as in the proxy setups in IE, etc)?

Highlighted

Re: Slow workflow execution

Hello stevenj,

In my case WFA service was running with an active directory account, because I use some workflows commandlet that needs credentials, as get-service for exemple.

So I had to login interactively  with this service account and set proxy setting or set via regedit the correct HKEY_USERS Keys

[S-1-5-21..........\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"MigrateProxy"=dword:00000001

"ProxyEnable"=dword:00000001

"ProxyHttp1.1"=dword:00000000

"ProxyServer"="http://ProxyServername:80"

François

Highlighted

Re: Slow workflow execution

Salut François,

We had such kind of issue with SnapManager Service for one of our customer.

There is an option in Internet Explorer called "Check for publisher's certificate revocation". I'm wondering if this option could help as well in your problem.

If this is enable, some programs needs an internet access.

That would be nice if you could give it a try

Cheers,

JC

View solution in original post

Highlighted

Re: Slow workflow execution

Hi jc,

You are totaly right.

Removing Check for publisher's certificate revocation fix the problem as well.

François

Highlighted

Re: Slow workflow execution

Was this done on the workstation that the workflows were executed from or on the server? What user account? Still seeing issues with the workflows taking about 45 seconds to load the powershell modules.

Highlighted

Re: Slow workflow execution

Ignore - Read the response.... Changed the setting under the user that runs the WFA Server Service and dropped the load from 45 seconds to under 2 seconds.

Thanks!!

Highlighted

Re: Slow workflow execution

Hi all.

Tried to do all the examples shown and still takes long time like other posts.

 

Tried to change the "revocation" setting in Internet Explorer, tried creating the powershell.exe.config file with relevant configuration, also tried removing executor="http-executor" from xml file and restarting service,  and server is already 2008R2.

 

Any other ideas?

WFA Server service runs with local system.

 

Thanks.

Highlighted

Re: Slow workflow execution

Hi Sinaa,

Was there a change on Netappp side? I have to change to v3.0 because compatibility with ocum 6.2 and the slowdown problem reoccurs, event certificate unchecked.

I tried to play with bug solution 802749 and standalone-full.xml. When I removed lines, the WFA server service won't to start any more.

For HTTP: <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http" executor="http-executor"/>
For HTTPS: <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true" executor="http-executor">

 

 

François

Highlighted

Re: Slow workflow execution

Francois:

 

Thanks for your reply.

Are you still facing the slow execution problem with WFA 3.0?


Regards

Abhi

Highlighted

Re: Slow workflow execution

Hello abhit,

 

Yes the problem reappears since ver 3.0, the workaround worked for 2.x version but not works in the last version.

An example for a simple clone take 98 sec to complete., before in 10 sec.

 

09:36:01.626 INFO [ITS Clone volume on Last Snapshot] ### Command 'ITS Clone volume on Last Snapshot' ### 09:36:03.048 INFO [ITS Clone volume on Last Snapshot] Get-WfaCredentials -Host 10.139.32.75

09:36:03.126 INFO [ITS Clone volume on Last Snapshot] Credentials successfully provided for '10.139.32.75'

09:36:03.235 INFO [ITS Clone volume on Last Snapshot] Connect-NaController (with credentials) -Name 10.139.32.75 -Timeout 60000 -ErrorAction Stop -HTTP 09:36:04.188 INFO [ITS Clone volume on Last Snapshot] Connected to controller 09:36:54.345 INFO [ITS Clone volume on Last Snapshot] Create a clone for Volume sge_fcp_mssql_gdc01467_01 , named sge_fcp_mssql_gdc01840_01_clone

09:37:40.049 INFO [ITS Clone volume on Last Snapshot] Command completed, took 98423 milliseconds

 

François

Re: Slow workflow execution

Hi Francois:

 

Sorry to hear that the issue is reappearing.

We have opened a bug in our tracking system.

The number is 909331.

We have not observed this internally, so we may ask you to share

some more information if we require.

 

Regards

Abhi

Highlighted

Re: Slow workflow execution

Francois,

          I've not tried removing the http-executors in wfa3.0. If that is the case, I'm not sure.

 

 I can suggest another thing which has worked for some others.

 

Upgrade your .NET version to 4.5 or later. Then after run the .NET repair tool from here.

 

http://www.microsoft.com/en-us/download/details.aspx?id=30135

 

Do it even if the .NET upgrade went fine and didn't throw any errors. Just download the repair tool and run it

 

 

sinhaa

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Highlighted

Re: Slow workflow execution

Hello sinhaa,

Yes I did, but after removing this key, I cannot start WFA server service any more.

For .NET I run WFA on W2K12R2 so 4.5 is installed as feature already.

François

Highlighted

Re: Slow workflow execution

 
Highlighted

Re: Slow workflow execution

Francois,

 

         Run the .NET repair tool and see if it helps.

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Check out the KB!
NetApp Insights To Action
All Community Forums