Data Infrastructure Management Software Discussions

Re: Slow workflow execution

sinhaa,

The idea was not to configure proxy settings in WFA server, can you tell me more about this unwanted traffic.

francois

Highlighted

Re: Slow workflow execution

Francois,

         Honestly, I don't know the answer right now. I'll post it once I find out.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Slow workflow execution

Regarding my case engineering opened a new bug for this issue.

http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=802749


Re: Slow workflow execution

Francois,

What exactly did you change within your server to get the workflow to speed up? Are you talking Internet settings (as in the proxy setups in IE, etc)?

Re: Slow workflow execution

Hello stevenj,

In my case WFA service was running with an active directory account, because I use some workflows commandlet that needs credentials, as get-service for exemple.

So I had to login interactively  with this service account and set proxy setting or set via regedit the correct HKEY_USERS Keys

[S-1-5-21..........\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"MigrateProxy"=dword:00000001

"ProxyEnable"=dword:00000001

"ProxyHttp1.1"=dword:00000000

"ProxyServer"="http://ProxyServername:80"

François

Re: Slow workflow execution

Salut François,

We had such kind of issue with SnapManager Service for one of our customer.

There is an option in Internet Explorer called "Check for publisher's certificate revocation". I'm wondering if this option could help as well in your problem.

If this is enable, some programs needs an internet access.

That would be nice if you could give it a try

Cheers,

JC

Re: Slow workflow execution

Hi jc,

You are totaly right.

Removing Check for publisher's certificate revocation fix the problem as well.

François

Re: Slow workflow execution

Was this done on the workstation that the workflows were executed from or on the server? What user account? Still seeing issues with the workflows taking about 45 seconds to load the powershell modules.

Re: Slow workflow execution

Ignore - Read the response.... Changed the setting under the user that runs the WFA Server Service and dropped the load from 45 seconds to under 2 seconds.

Thanks!!

Re: Slow workflow execution

Hi all.

Tried to do all the examples shown and still takes long time like other posts.

 

Tried to change the "revocation" setting in Internet Explorer, tried creating the powershell.exe.config file with relevant configuration, also tried removing executor="http-executor" from xml file and restarting service,  and server is already 2008R2.

 

Any other ideas?

WFA Server service runs with local system.

 

Thanks.

Forums