Data Infrastructure Management Software Discussions

Re: Slow workflow execution

Any update to this?   I'm seeing the same thing at a customer with 2.2.

Re: Slow workflow execution

The odd thing is that even the no-op (cluster mode) command takes almost 400 seconds in execute mode.  But in preview mode it runs as you would expect.

Re: Slow workflow execution

Have you tried running Powershell itself and time it, then load the "profile.ps1" in the <WFA>/PoSH folder and time that. (cd <wfa>\PoSH ;; .\profile.ps1)

I've found installing additional powershell extensions on the WFA machine, when there were configuration issues, or even the built-in ones, can cause long delays to launching and some logging commands.

Each time a command is run, even a No-Op, a new powershell.exe instance is launched and loads the profile that loads additional modules. If you run a lot of commands and there's a delay there, that time can add up.


Re: Slow workflow execution

Adding to Michael's reply, can you run the following and send the output?

1. Open cmd prompt

2. Run command systeminfo and send me the output here or at sinhaa at netapp dot com

The thing is this issue is perhaps a JBOSS7 issue and JBOSS7 is what WFA2.1 onwards is using. We can give you a way to reduce the long delays.

warm regards,


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Slow workflow execution

I opened a case, no answers for the moment.



Re: Slow workflow execution

Hi Francois and aparker,

DISCLAIMER: This solution is still under test and not guaranteed to work or not to cause any other issues. But its looks harmless to me.

      Please try the following JBoss config modification. Thanks to Sandeep for working on it.

1. Open file standalone-full.xml located at WFA\jboss\standalone\configuration for editing using some text editor like notepad++

2. Find the line : <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http" executor="http-executor"/>

and for HTTPS

     <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true" executor="http-executor">

3. Remove the executor="http-executor" from them

4. Save the file.

5. Restart NetApp WFA Server service and wait for the service to be up.

6. Retest your command or workflow execution.

Let me know how this worked for you.

warm regards


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Slow workflow execution

Hi sinhaa,

The modification doesn't help very much, seems better, but still more than minute.

15:29:52.405 INFO  [Remove volume] ### Command 'Remove volume' ###

15:31:08.394 INFO  [Remove volume] Executing command: ./Remove_volume3469935687972074943.ps1 -Array '' -VolumeName 'test'



Re: Slow workflow execution


         Does loading of powershell itself takes long time in your server?

Do the following:

1. Try to open Powershell CLI by typing command "powershell" in you command prompt. Does it take a long time?

2. Once Powershell is open, try this command "Import-Module <WFA>/PoSH/profile.ps1 . Does it take long to complete?

3. Type cmd : systeminfo and send the output.


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Slow workflow execution

Hi sinhaa,

1. powershel prompt was loaded quickly < 5 seconds

2. Multiple loads of  profile.ps1 arround ~1:30 minutes


  Host Name:                 GDC01249

OS Name:                   Microsoft Windows Server 2008 R2 Datacenter

OS Version:                6.1.7601 Service Pack 1 Build 7601

OS Manufacturer:           Microsoft Corporation

OS Configuration:          Member Server

OS Build Type:             Multiprocessor Free

Registered Owner:          SDS

Registered Organization:   The Swatch Group Ltd

Product ID:                00496-001-0001283-84686

Original Install Date:     9/11/2013, 5:27:54 PM

System Boot Time:          1/21/2014, 5:12:31 PM

System Manufacturer:       VMware, Inc.

System Model:              VMware Virtual Platform

System Type:               x64-based PC

Processor(s):              1 Processor(s) Installed.

                           [01]: Intel64 Family 6 Model 44 Stepping 2 GenuineIntel ~2666 Mhz

BIOS Version:              Phoenix Technologies LTD 6.00, 7/30/2013

Windows Directory:         C:\Windows

System Directory:          C:\Windows\system32

Boot Device:               \Device\HarddiskVolume1

System Locale:             en-us;English (United States)

Input Locale:              en-us;English (United States)

Time Zone:                 (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna

Total Physical Memory:     2,047 MB

Available Physical Memory: 74 MB

Virtual Memory: Max Size:  6,143 MB

Virtual Memory: Available: 2,850 MB

Virtual Memory: In Use:    3,293 MB

Page File Location(s):     P:\pagefile.sys


Logon Server:              \\GDC00945

Hotfix(s):                 175 Hotfix(s) Installed.

                           [01]: KB2592687

                           [02]: KB2425227



Network Card(s):           1 NIC(s) Installed.

                           [01]: vmxnet3 Ethernet Adapter

                                 Connection Name: Local Area Connection

                                 DHCP Enabled:    No

                                 IP address(es)



Re: Slow workflow execution

Looks like this loading of profile.ps1 is taking all the time and hence the delays. Its mainly your environment issue, but I don't exactly know what it is and why. Can you try the following

1. Lauch powershell and  Import-Module <WFA>\PoSH\Modules\WFA

   Import-Module <WFA>\PoSH\Modules\DataONTAP

How long do they take? I'm just thinking is the profile.ps1 loading slow due to relative path that it has in its code. Normally its not a problem, but could be.

Abhishek Sinha

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.