Data Infrastructure Management Software Discussions

Re: Slow workflow execution

Aparker is working with me onsite.  We tried the fix but that didn't help. 

The import of the modules is quick.

Here is the systeminfo from aparker's VM:

Host Name:                

OS Name:                   Microsoftr Windows Serverr 2008 Enterprise

OS Version:                6.0.6002 Service Pack 2 Build 6002

OS Manufacturer:           Microsoft Corporation

OS Configuration:          Standalone Server

OS Build Type:             Multiprocessor Free

Registered Owner:          Windows User

Registered Organization:

Product ID:                55041-381-2247303-76321

Original Install Date:     1/27/2014, 3:38:26 PM

System Boot Time:          2/19/2014, 8:14:06 AM

System Manufacturer:       VMware, Inc.

System Model:              VMware Virtual Platform

System Type:               x64-based PC

Processor(s):              2 Processor(s) Installed.

                           [01]: Intel64 Family 6 Model 29 Stepping 1 GenuineIntel ~2400 Mhz

                           [02]: Intel64 Family 6 Model 29 Stepping 1 GenuineIntel ~2400 Mhz

BIOS Version:              Phoenix Technologies LTD 6.00, 1/15/2013

Windows Directory:         C:\Windows

System Directory:          C:\Windows\system32

Boot Device:               \Device\HarddiskVolume1

System Locale:             en-us;English (United States)

Input Locale:              en-us;English (United States)

Time Zone:                 (GMT-08:00) Pacific Time (US & Canada)

Total Physical Memory:     8,191 MB

Available Physical Memory: 5,887 MB

Page File: Max Size:       16,429 MB

Page File: Available:      13,908 MB

Page File: In Use:         2,521 MB

Page File Location(s):     C:\pagefile.sys

Domain:                    WORKGROUP

Logon Server:             

Hotfix(s):                 2 Hotfix(s) Installed.

                           [01]: KB955430

                           [02]: KB968930

Network Card(s):           1 NIC(s) Installed.

                           [01]: Intel(R) PRO/1000 MT Network Connection

                                 Connection Name: Local Area Connection

                                 DHCP Enabled:    No

                                 IP address(es)

Re: Slow workflow execution

Here the test from wfa server, :

PS C:\Users\itsfe> Measure-Command {import-module 'C:\Program Files\NetApp\WFA\PoSH\Modules\WFA'}

TotalSeconds      : 0.0463199


PS C:\Users\itsfe> Measure-Command {import-module 'C:\Program Files\NetApp\WFA\PoSH\Modules\DataONTAP'}

TotalSeconds      : 74.4140401

Note in my personnal computer I use for developement  DataONTAP module is loaded very quickly

PS C:\Users\eggerf> Measure-Command {import-module 'C:\Windows\System32\WindowsPowerShell\v1.0\Modules\DataONTAP'}

TotalSeconds      : 0.580509

Re: Slow workflow execution

To follow-up on this, we may be seeing some different issues.    What we are seeing at our customer (a major US bank) is that it takes about 5 MINUTES for each WFA command block to start execution.      The server being used is pretty much cut off from the outside world, so I thought it may have had something to do with checking for certificate revocation.     But we tried disabling that by various methods, including as shown in this article:

Nothing made a difference.   If we open a powershell window on the server, it seems to open in a normal amount of time.    If we load the ONTAP module, it loads normally and quickly.   So we don't see the issue by using the powershell command window.

Our onsite guy at the customer is going to look into getting the server more outside access or adding it to the domain (which is currently isn't on).

-Alan Parker

Re: Slow workflow execution

Francois, Parker,

     I don't know what else can I suggest you to try. I just can't think of anything as of now.

Maybe you can try to upgrade the WFA server to .NET 4.5 version and if possible to Powershell 3.0 and see if it helps.


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Slow workflow execution

Upgraded to both...still doesn't help.

Re: Slow workflow execution

Hi sinhaa,

Do you know if some kind of certificates check is used for ONTAP module?

I traced communication during load of module, and process tried to access port 80.

3573          184.174793000          TCP          66          52724 > http [SYN] Seq=0 Win=8192 Len=0 MSS=1460 WS=256 SACK_PERM=1

Following this fact,  I configured proxy in Server.

11:18:14.316 INFO  [Remove volume] ### Command 'Remove volume' ###

11:18:36.499 INFO  [Remove volume] Executing command: ./Remove_volume6766461420913838121.ps1 -Array '' -VolumeName 'test'

11:18:36.655 INFO  [Remove volume] Get-WfaCredentials -Host

11:18:37.014 INFO  [Remove volume] Credentials successfully provided for ''

11:18:37.139 INFO  [Remove volume] Connect-NaController (with credentials) -Name -Timeout 60000 -ErrorAction Stop

11:18:42.536 INFO  [Remove volume] Connected to controller

11:18:44.861 INFO  [Remove volume] Removing all volume quotas, volume name: test

Workflow speed is miraculous good now

Re: Slow workflow execution

How much of a delay did you have before?


Re: Slow workflow execution

Upgrade to 2008R2 earlier today and our 5 minute wait seemed to have  disappeared.  Not sure what fixed because the upgrade kept all the  settings and it wasn't a clean install.

Re: Slow workflow execution

2 minutes


Re: Slow workflow execution

I'm glad it has  finally worked for both of you.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.