Data Infrastructure Management Software Discussions

Highlighted

System Manager 3.0 - NTP error

Hello,

I'm using System Manager 3.0 on Windows 2008R2 and Windows 7.

if I try to set an NTP Server I get the following error:

==ERROR==

  1. com.netapp.sysmgr.client.api.NaApiFailureException

==TIME==

2014-01-03 10:59:31,221

==MESSAGE==

Invalid or incomplete XML received due to communication error or character encoding errors. (Error: 0)

==DETAILS==

Failed to parse: <netapp version='1.1' xmlns='http://www.netapp.com/filer/admin'>

<results status="failed" errno="13001" reason="Unable to set op

==CORRECTIVE ACTION==

In case of communication error, refresh the browser and try again. In case of character encoding errors, use UTF-8 character encoding.

==LOCATION==

Location is not specified.

==BROWSER INFO==

App Name: Netscape

App Version: 5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

App Codename: Mozilla

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Platform: Win32

Cookie Enabled: true

Why does the system not fix this automatically or offers a button "configure that"?

Thanks

Hannes

11 REPLIES 11
Highlighted

Re: System Manager 3.0 - NTP error

Hi Hannes,

Is this the same Windows server from this post?

https://communities.netapp.com/message/123139#123139

What text were you configuring in the NTP server field?

Thanks,

Kevin

Highlighted

Re: System Manager 3.0 - NTP error

Hi,

yes, it is the same (also tested on different Windows7)

The Server was 0.at.pool.ntp.org

Best regards,

Hannes

Highlighted

Re: System Manager 3.0 - NTP error

Hi Hannes,

To confirm - the string you entered in that field was "0.at.pool.ntp.org"?

Thanks,

Kevin

Highlighted

Re: System Manager 3.0 - NTP error

Hannes,

I was able to configure that server in my NTP settings using OCSM 3.1RC1 and ONTAP 8.0.3 7-mode. 

We will have to review the logs covering this error which should be in the same set already collected from you. 

Can I safely assume that the error occurred shortly before the first post in this thread (?

Thanks,

Kevin

Highlighted

Re: System Manager 3.0 - NTP error

Hi,

yes, the server is correct.

Hmm, maybe it is fixed in 3.1.

Did you try to set the server without configuring a DNS server on the Netapp? I cannot try but if I remember correctly I did not configure DNS which should result in a "DNS not configured" error.

Yes, all the errors occured during one day of testing (also my third post).

Best regards,

Hannes

Highlighted

Re: System Manager 3.0 - NTP error

Hi Hannes,

Disabling DNS did it - I now observe the same error as you did when attempting to add a server name to the NTP field.  It does not error when adding an ip (as expected).

I will file a bug to change this behavior.

Thanks,

Kevin

View solution in original post

Highlighted

Re: System Manager 3.0 - NTP error

Just to be clear, this error is returned from ONTAP, not OCSM - OCSM is just delivering the message.

Thanks,

Kevin

Highlighted

Re: System Manager 3.0 - NTP error

Hi Kevin,

I'm glad that we found the source of the error 🙂

Thanks for helping.

Best regards,

Hannes

Highlighted

Re: System Manager 3.0 - NTP error

Just try Open system manager  in diffrent browser ..it will work like charm...) IE 11 or Chrome , etc...

Highlighted

Re: System Manager 3.0 - NTP error

And again to be clear, diffrent browser is only for addressing the below  error..

 

"Invalid or incomplete XML received due to communication error or character encoding errors. (Error: 0)"

Highlighted

Re: System Manager 3.0 - NTP error

I was also getting :- "Invalid or incomplete XML received due to communication error or character encoding errors. (Error: 0)" while trying to log into System Manager  from a Windows 2012 R2 server using IE 11. I fixed it by adding the IP address of the Cluster into the list of Trusted Sites in the security settings of IE11.
Check out the KB!
Knowledge Base
All Community Forums