Data Infrastructure Management Software Discussions

Highlighted

Unable to add Storage Controller - Connection failure

I'm unable to add Netapp Storage contoller to WFA tool.... Please check the screenshot below

When i used the same credentials to login either from Putty or Directly from Http i was able to login to the Filer. Can somebody help??

14 REPLIES 14
Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Mahesh,

I've been unable to reproduce this issue. A few queries to help understand this problem better:

  • What is the version of WFA that you are using?
  • Have you tried adding a storage controller different from the one that you have mentioned? Do you see this issue consistently with other NetApp storage controllers too?
  • Can you execute a simple ZAPI(egs. to retrieve version) on the mentioned storage array and verify if it executes successfully.

Regards,

Tanzim

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Tanzim,

  • The Version of WFA is WFA-x64-V2.0.0.391.2-B11275
  • I only have access to a single Storage Test Controller, because others are production arrays. I have to ask for access to another array, that might take time.
  • I'm able to login to the array via Putty and execute all commands, i can also login via http through the same credentials.

Regards

Mahesh

Re: Unable to add Storage Controller - Connection failure

Hi Tanzim,

     I tried with another storage controller also but getting same peoblem as above. i tried with root id too, didn't work. Can you help me??

Regards

Mahesh

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Mahesh,

I definitely will do my best to help you . A couple of queries more (hopefully the last set!):

  • Can you provide me the hardware/software details of your controllers?
  • Please provide the corresponding WFA logs.

Regards,

Tanzim

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Mahesh,

I've not heard from you in a while.

Can i assume that the credentials issue has been resolved and you're happily executing workflows ?

If yes, please could you provide the resolution?

Thanks,

Tanzim

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Tanzim,

     Can you reply me back with ur mail id, so that i can mail you the WFA Logs and System details. Thanks in Advance.

Regards

Mahesh.P

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Mahesh,

You can mail me at : tanzim@netapp.com

Regards,

Tanzim

Highlighted

Re: Unable to add Storage Controller - Connection failure

Mahesh, pleas check "options httpd.admin.enable" on the storage controller. This setting needs to be on

View solution in original post

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Siva Ramanathan,

                              It worked for me, thanks a lot for you help.

Regards

Mahesh.P

Highlighted

Re: Unable to add Storage Controller - Connection failure

Is having OnCommand Unified Manager or Vsphere as a data Acquisition unit mandatory for WFA to work? i'm unable to execute any workflows. By default the Workflow is executing on aggr0 which is the default Boot volume.Can anyone help, Please send me any good documents where i can start testing on WFA Workflows.Thanks

Mahesh.P

Highlighted

Re: Unable to add Storage Controller - Connection failure

Mahesh,

You have mentioned quite a few points, i will address them individually:

  • "Is having OnCommand Unified Manager or Vsphere as a data Acquisition unit mandatory for WFA to work"

         It is not mandatory to have a data acquisition unit (data source) for WFA to work(implying workflow execution). In this case, the user has to define all the       objects required by the corresponding  workflow to execute.

         Having said that,it is recommended to add data sources to facilitate object selection (based on intelligent criteria defined in the filter/finder used) during workflow execution. This removes the overhead on the user to explicitly define the objects in the workflow.

  • "i'm unable to execute any workflows"

         Can you be more specific here?

         Have your workflow executions resulted in errors? If yes,please mention them.

  • "By default the Workflow is executing on aggr0 which is the default Boot volume"

         Which is the workflow that you are referring to? What is the point of contention here?

  • "Please send me any good documents where i can start testing on WFA Workflows"

         A good document to start would be the "OnCommand Workflow Automation Installation and Setup Guide"  that can be picked up from the NetApp Support site.

       There are some really good related videos on the community. A couple of them(Courtesy : Kevin Hill) more relevant to you :

      1. Building your first workflow
      2. Workflow Automation Technical Introduction

       NOTE : Both these videos are part of a larger training series : WFA How-To Video Series

Regards,

Tanzim

Message was edited by: Tanzim Rahmathullah

Highlighted

Re: Unable to add Storage Controller - Connection failure

Thanks For your Quick reply,

      1.  when i'm executing a workflow this is what i'm getting

2. When i tried using filters to get all the aggregates in the Array by IP:

This is what i got, it was showing no aggregates in the array.But when i check through Putty:

This is what it shows....

and ya Thanks for the Videos....

Regards

Mahesh.P

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hi Mahesh,

The error you are receiving states your issue on the second line "No Results were found".

This is where the sample workflow you are executing is trying to be intelligent about the placement of your new volume & share. This is where datasources are used.  WFA will acquire information about your storage controllers by collecting that information from Unified Manager.  Without it, it is still possible to update the workflow where you have to put in all if the information via user inputs.

Tanzim is correct that technically it is possible to run WFA without datasources.  However, it is unadvisable to do so.  Is there a specific reason you are not using Unified Manager in your environment?  You will have a much better experience with WFA if you start using Unified Manager as a datasource.

Best,

Kevin

Highlighted

Re: Unable to add Storage Controller - Connection failure

Hello Mahesh,

To add to what Tanzim said:

There is no required data source and WFA can work with out it. With that said, the resource selection mechanism (Using finders) will not work without data sources.
It is highly recommended at least to have one OCUM as a data source, as it would give you most of the needed info on NetApp storage it monitors.

Regarding workflows not executing due to using mostly aggr0:

Some of our certified finders exclude aggr0 in their search for a valid aggregate. If you mostly use those, it might be good for you to select the filters that you want ad hoc and save them as a finder of your own.
That would make sure that aggr0 would be a valid option (Obviously if you won't select that "Aggregate is not aggr0" filter for your finder :-))

BR,

Yaron Haimsohn

Check out the KB!
Knowledge Base
All Community Forums