Data Infrastructure Management Software Discussions

Unified Manager upgrade failed from 7 to 7.1


Hello Everyone,



We tried to upgrade unified manager from 7.0 to 7.1P3 using the ISO file by following the below steps

After step 12 it throws an error message stating failed loading the ISO file.

We mounted the ISO file from CD/DVD and from Datastore as well still we got the same error at step 12

We checked the checksum value of the downloaded file, it looks same as mentioned in NetApp site.



  1. In the vSphere Client, click Home > Inventory > VMs and Templates.
  2. Select the virtual machine (VM) on which the Unified Manager virtual appliance is installed.
  3. If the Unified Manager VM is running, navigate to Summary > Commands > Shut DownGuest.
  4. Create a backup copy—such as a snapshot or clone—of the Unified Manager VM to create an application-consistent backup.
  5. From the vSphere Client, power on the Unified Manager VM.
  6. Click the CD/DVD Drive icon, and select Connect to ISO image on local disk.
  7. Select the OnCommandUnifiedManager-7.2-virtual-update.iso file, and click Open.
  8. Click the Console tab.
  9. Log in to the Unified Manager maintenance console.
  10. In the Main Menu, select Upgrade.

A message is displayed that Unified Manager will be unavailable during the upgrade process, andwill resume after completion.

  1. Type y to continue.

A warning is displayed, reminding you to back up the virtual machine on which the virtual appliance resides.

  1. Type y to continue.

The upgrade process and the restart of Unified Manager services can take several minutes to complete.

Attention: Because of a change to the upgrade script, the first time you upgrade from Unified

Manager 7.1 you will see the message the upgrade mechanism has been updated, please restart the upgrade process. You must restart the upgrade process at this point.



exact error is ISO mount failed . we copied ISO on a datastore and we were able to see that CD drive was connected in summary tab-->hardware section of the VM in vcenter.


anyone came across same error?




Re: Unified Manager upgrade failed from 7 to 7.1



Can you check if the .iso is mounted? 


Right click

edit settings\cd/dvd drive\

device status needs to be checked.


Then go back to the management console, run upgrade, upgrade should work. See attached screenshot for details.


You may have seen a mount error on the Virtual Center. That error message should be dismissed before the upgrade process can begin.


Let me know if this helps.



Re: Unified Manager upgrade failed from 7 to 7.1

Hi Julia, I did that device status check and it shows connected but still the error stays same ISO mount failed.

is there any way to go into the appliance and check if the appliacne it self able to see the mounted ISO rather than chaking from vmware side?

that will be a real check to make sure its mounted correctly.



Re: Unified Manager upgrade failed from 7 to 7.1


In the initial notes I see that the upgrade was attempted from 7.0 to 7.1P3 but in the detailed
steps I am seeing that OCUM 7.2 ISO was selected for upgrade ie, in step 7 "Select the
OnCommandUnifiedManager-7.2-virtual-update.iso file".
You can upgrade to Unified Manager version 7.2 only from instances of Unified Manager 7.1.


Re: Unified Manager upgrade failed from 7 to 7.1

its just mistake in the instructions, i chose the correct ISO but still the mount failed error stayed.

Re: Unified Manager upgrade failed from 7 to 7.1



You may need to call Customer Support so someone can take a look at your Unified Manager and assist you resolving the issue.





Re: Unified Manager upgrade failed from 7 to 7.1


we hit above but and asked to follow below path


we need to upgrade to 7.0P1 then to 7.1P3 and then 7.2



View solution in original post

Cloud Volumes ONTAP
Review Banner
All Community Forums