Data Infrastructure Management Software Discussions

Highlighted

Upgrade from 6.4 to OCUM & OPM 7.0

Hello,

 

Does anyone know how we can clean up false credentials between OCUM & OPM after upgrade ?

 

After an Upgrade vom 6.4 to 7.0 I got following message in the dashboard for some systems with ONTAP9.

The issues is fixed as soon as I remove a cluster and add it again, but I will lost all the history.

 

"The credentials provided by Performance Manager for the user with Event Publisher role are either incorrect or Performance poll is not complete or has failed."

 

Best regards,

Marc

17 REPLIES 17
Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

You can go to the new dashboard (landing page), and edit the cluster. The "Edit cluster" page has options for you to provide new username and password.

 

 

The new credentials you enter will be updated in both OCUM and OPM server.   It should work.  If it doesnt work, please let us know.

 

 

Regards,

Saravanan

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Hello

I tried it, but it doens't work. I think it's not problem by the credentials.
Do you have any additional ideas?

Best regards
Marc
Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I am having the same issue with 7.0RC1 and I've reset permissions on that account several times.  I'm also conviced it's not actually a permissions issue.

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I had a bad combo of user/password. After the upgrade, I created a new account and applied that. I noticed it was helpful to go ahead and restart the service first on Unified Manager followed by Perf Mgr. Pairing showed up healthy.

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I added a second cluster to UM today and it worked fine with PM so I'll reset everything and see how it goes. Thanks!
Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Now we have two workarounds, but no idea how we can fix it without a new account or the lost of the history.

 

@dmcneil Did you switch back to the admin user? (I can't test it right now.)

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I have found that my instance of 7 finally crashed and became inoperable. There may be some workarounds now so that may fix things. But history was lost 

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Just in case anyone else runs into this issue.

 

The way to resolve it is to modify full integration settings (if option is enabled). Once you start to go through the diffrenet fields you will find that one of the opttions is a new account, called publisher admin.

 

6.4 did not have this account in the past, that is why the error is coming up. Once you set username and passwd for the publisher account and restart Performance manager services, OCUM will stop displaying the error. 

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Hallo

 

Iam having the same Problem hier with OCUM  7.1P1  & OPM  7.1P1  

 

 

Monitoring staus

 

Pairing Status
(Bad):

The credentials provided by Performance Manager for the user with Event Publisher role are either incorrect or Performance poll is not complete or has failed.

 

Any ideas where the Problem can be ?

 

Thanks

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Hi,

Recently run into this too...

Re created Event Publisher user and restarted servers... same issue after polling.

Tryed to delete clusters from OCUM and error appeared: 

Cannot delete cluster as the cluster delete failed for the associated Performance Manager instance.

Unable to find OPM ...8f42...long..string............ in RP registry

I had opened a case, I will update this sometime.

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

you can fix this issue by:

1. login to the cluster and remove the old record of the OCPM:

# set d 

# application-record show

 

you will get list....

 

delete the OCPM record by:

application-record delete [the OCPM name record]

 

2.now you need to login the OCUM / OCPM and go to Manage Cluster windows,

edit the recorde of the problematic cluster, and reassign it,

 

wait 15 min and you will see that the OCPM will start working.

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

could please share upgrade procedure and docus. i am plaining for this upgrade.

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

Hi ANANDONTAP,

 

unfortunately you missed the window of opportunity.

Both versions, 6.4 and 7.0 are rather old and had their End of Version Support date back in January.

With this date the release is being pulled from our download site and all content is archived as there is no more maintenance on any of the materials and there were no security fixes in 7.0 since May 2017.

 

So unfortunately that leaves you with two choices only

 

#1 Install a more recent version from scratch. You won't be able to take historical data along.

 

#2 Find somebody in the greater NetApp community who happens to have kept a version of the 7.0 install/update file

 

Btw. 7.1 has already reached End of Engineering support (meaning no more code maintenance) and will reach End of Version Support by December 2018.

So best to go with at least 7.2 or even better, 7.3.

 

Sorry to not have better news for you.

 

Kind regards, Niels

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

i got your point, but this is our first upgrade, so we cant jum directly 7.2 or 7.3.

 

did you have any upgrade step by step producer for OCUM and OPS manager share to me

 

Thanks,

 

Highlighted

Re: Upgrade from 6.4 to OCUM & OPM 7.0

I just saw that the documentation is still available on the support site.

 

OCUM:

https://mysupport.netapp.com/documentation/productlibrary/index.html?productID=61373

 

OPM:

https://mysupport.netapp.com/documentation/productlibrary/index.html?productID=61809

 

Unfortunately the binaries have been pulled for the reason mentioned above.

So unless you happen to have those already you would need to re-install a newer version from scratch.

 

regards, Niels

Check out the KB!
NetApp Insights To Action
All Community Forums