Data Infrastructure Management Software Discussions

how can I reset my netapp

My company has a FAS3020c.  We recently moved into a new building and at the same time changed our internal vlan IP addresses.  I don't know any ips of the Netapp, so I'm not sure if it's on the old subnet or the net one.  And if you ask why I don't go ask someone at the company who would know, I did and the IP's I got don't ping/unable to access. :-(

Other than using the console cable (which I don't have so I can't use it), how can I connect to it to log in and change the IP?  Also, when I connect the "console" port to anything, I don't get any link lights (at least on the switch).  However when I connect the "RLM" port, which I don't know what it is, I get link activity.  Through the switch I tried to do an IP scan on the old subnet, but wasn't able to find the Netapp (tried all of the up IP's).  Can I plug a rj45 directly into either port and connect directly via...what, http?  Do I need to use a crossover cable?

Also, the lack of documentation and finding it on Netapp's site is discouraging.  I found a 2 page "install & setup instructions" (if you can call 2 pages a guide), but if anyone has a more detailed manual (for dumber people like me), can you share a link?



Re: how can I reset my netapp

Even if you find the right IP you still need user/password and if you do not have it, you need console where you can reset root password. Console cable is pretty standard - any Cisco console cable would do; settings are 9600,8bit,no partity. Press Ctrl-C for special boot menu and chose to set root password. Or reinstall ☺

You should look for Data ONTAP manuals, not for hardware manuals.

Re: how can I reset my netapp

Hi Justin,

If you never configured the RLM you could try to connect a Laptop with a DHCP Server (TFTPD: to the RLM Interface. If the RLM gets an IP you can connect with SSH to the interface and login with user "naroot" and the root password from the Filer.

with "system console" you get the usual CLI commands that you are used from logging in directly to the Filer

Re: how can I reset my netapp

Thanks, the cisco cable worked great.  I was able to get into the console, but still cannot access the IP address.  I changed the RLM IP to the new subnet.

1) Is FilerView a downloadable app that I need in order to use web based GUI?

2) Is the RLM IP address where I should be setting the IP?

Re: how can I reset my netapp

FilerView is part of Data ONTAP until version 8.1. It is possible in principle to have working Data ONTAP without FilerView; to make sure system is completely and properly installed you could perform update to the same (or latest) version.

RLM is separate piece of hardware unrelated to Data ONTAP; you cannot access Data ONTAP via RLM (only indirectly by connecting to console). You need to configure one of “normal” filer interfaces. e0a usually is always present ☺

Re: how can I reset my netapp

Hi Justin

When you hooked up the cable at the back of the controller you more or less went straight into the controllers motherboard as you know.

The RLM does the same but over the LAN and is secured as well. It is recommended to login either directly at back of controller or via RLM

when changing IPs, this will ensure you wont lose connection to the controller.

However you do need usernames/passwords to login past the RLM and into the controller. Did you manage to get into a prompt on the controller? It sounds like you did actually.

If thats the case make sure you create yourself a user you can use for logins:

useradmin use add -g administrators

Once you ve logged into the controller you should be able to manage the IPs:

ifconfig -a      list all IPs

ifconfig e01 netmask up  > will configure an IP on NIC in slot E, port 1.

The other thing is you might find that the NICs/Ports are bundled into what we call VIFs, You can find out by running:

vif status

You ll get an idea of the config by reading /etc/rc file: rdfile /etc/rc    > look for "vif create" command.


PS: if you need to reset root password that is only done over a reboot.. You ll need to reboot, press ctrl-c and chose the reset root password option.

Re: how can I reset my netapp

Awesome, thanks for the help.  I now need to find out what the errors are that I'm seeing, but I'll start a new thread about that.  Thanks for the assistance!