Data Infrastructure Management Software Discussions

netapp harvest 1.6 install rpm rhel 6

anyone has similar issues on rhel 6 

already have it installed but still get this error dependancy

ls /usr/local/share/perl5/HTTP/Tiny.pm -l

-r--r--r-- 1 root root 78254 Aug  5  2018 /usr/local/share/perl5/HTTP/Tiny.pm

 

 

sudo yum install -y  /tmp/netapp-harvest-1.6-1.noarch.rpm

Loaded plugins: priorities, product-id, rhnplugin, search-disabled-repos, security, subscription-manager

This system is not registered with an entitlement server. You can use subscription-manager to register.

This system is not registered with RHN Classic or RHN Satellite.

You can use rhn_register to register.

RHN Satellite or RHN Classic support will be disabled.

Setting up Install Process

Examining /tmp/netapp-harvest-1.6-1.noarch.rpm: netapp-harvest-1.6-1.noarch

Marking /tmp/netapp-harvest-1.6-1.noarch.rpm as an update to netapp-harvest-1.4.2-1.noarch

Resolving Dependencies

--> Running transaction check

---> Package netapp-harvest.noarch 0:1.4.2-1 will be updated

---> Package netapp-harvest.noarch 0:1.6-1 will be an update

--> Processing Dependency: perl(HTTP::Tiny) for package: netapp-harvest-1.6-1.noarch

--> Finished Dependency Resolution

Error: Package: netapp-harvest-1.6-1.noarch (/netapp-harvest-1.6-1.noarch)

           Requires: perl(HTTP::Tiny)

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles –nodigest

 

also doesnt run with -skip-broken

verified good rpm download

rpm -Va --nofiles –nodigest

2 REPLIES 2
Highlighted

Re: netapp harvest 1.6 install rpm rhel 6

yum will only resolve the dependency correctly if you have installed the corresponding perl module via yum/rpm. So you can't solve this by getting the files directly from CPAN. Afaik there is no perl-HTTP-Tiny package availabe from RedHat or EPEL for RHEL6. Maybe you can get it from another repo.

It is available for RHEL7 though, so if you have the possibility to upgrade, that would be an option.

View solution in original post

Highlighted

Re: netapp harvest 1.6 install rpm rhel 6

I was facing issues while installing netapp-harvest-1.6-1.noarch.rpm

Everytime I install it says its not installed and give me list of dependencies. 

 

Platform:- Azure VM with Centos 7.5 (minimal install)

after running  #yum install netapp-harvest-1.6-1.noarch.rpm --skip-broken

its gave me below dependencies those are required:- 

netapp-harvest-1.6-1.noarch from /netapp-harvest-1.6-1.noarch
perl-Business-ISBN-2.06-2.el7.noarch
perl-Business-ISBN-Data-20120719.001-2.el7.noarch
perl-Compress-Raw-Bzip2-2.061-3.el7.x86_64
1:perl-Compress-Raw-Zlib-2.061-4.el7.x86_64
perl-Data-Dumper-2.145-3.el7.x86_64
perl-Digest-1.17-245.el7.noarch
perl-Digest-MD5-2.52-3.el7.x86_64
perl-Encode-Locale-1.03-5.el7.noarch
perl-File-Listing-6.04-7.el7.noarch
perl-HTML-Parser-3.71-4.el7.x86_64
perl-HTML-Tagset-3.20-15.el7.noarch
perl-HTTP-Cookies-6.01-5.el7.noarch
perl-HTTP-Daemon-6.01-8.el7.noarch
perl-HTTP-Date-6.02-8.el7.noarch
perl-HTTP-Message-6.06-6.el7.noarch
perl-HTTP-Negotiate-6.01-5.el7.noarch
perl-IO-Compress-2.061-2.el7.noarch
perl-IO-HTML-1.00-2.el7.noarch
perl-IO-Socket-IP-0.21-5.el7.noarch
perl-IO-Socket-SSL-1.94-7.el7.noarch
perl-JSON-2.59-2.el7.noarch
perl-LWP-MediaTypes-6.02-2.el7.noarch
perl-LWP-Protocol-https-6.04-4.el7.noarch
perl-Mozilla-CA-20130114-5.el7.noarch
perl-Net-HTTP-6.06-2.el7.noarch
perl-Net-LibIDN-0.12-15.el7.x86_64
perl-Net-SSLeay-1.55-6.el7.x86_64
1:perl-TimeDate-2.30-2.el7.noarch
perl-URI-1.60-9.el7.noarch
perl-WWW-RobotRules-6.02-5.el7.noarch
perl-libwww-perl-6.05-2.el7.noarch

 

not working with  rpm -Va --nofiles –nodigest

 

I installed all the dependencies still its says: 

  [root@az-nlsrvup-smo01 tmp]# yum install netapp-harvest-1.6-1.noarch.rpm
Loaded plugins: fastestmirror
Examining netapp-harvest-1.6-1.noarch.rpm: netapp-harvest-1.6-1.noarch
Marking netapp-harvest-1.6-1.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package netapp-harvest.noarch 0:1.6-1 will be installed
--> Processing Dependency: perl(Excel::Writer::XLSX) for package: netapp-harvest-1.6-1.noarch
Loading mirror speeds from cached hostfile
* base: ftp.tudelft.nl
* extras: centos.mirror.triple-it.nl
* updates: ftp.nluug.nl
--> Finished Dependency Resolution
Error: Package: netapp-harvest-1.6-1.noarch (/netapp-harvest-1.6-1.noarch)
Requires: perl(Excel::Writer::XLSX)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@az-nlsrvup-smo01 tmp]#

 

* perl-5.16.3-295.el7.x86_64   --- Already shows installed . 

Download the perl(Excel::Writer::XLSX) from below link 

https://armv7.dev.centos.org/repodir/epel-pass-1/_imported_noarch_pkgs_from_epel/epel/Packages/p/perl-Excel-Writer-XLSX-0.84-1.el7.noarch.rpm 

 

Install the perl-Excel-Writer XLSX and netapp-harvest will be installed fine. 

 

Now another issue arises, even after it saying installed but while doing query its again says NOT INSTALLED.

 

[root@az-nlsrvup-smo01 tmp]# yum install netapp-harvest-1.6-1.noarch.rpm
Loaded plugins: fastestmirror
Examining netapp-harvest-1.6-1.noarch.rpm: netapp-harvest-1.6-1.noarch
Marking netapp-harvest-1.6-1.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package netapp-harvest.noarch 0:1.6-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================================================================================
Installing:
netapp-harvest noarch 1.6-1 /netapp-harvest-1.6-1.noarch 5.0 M

Transaction Summary
================================================================================================================================================================================================================
Install 1 Package

Total size: 5.0 M
Installed size: 5.0 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
### Creating netapp-harvest group ... OK
### Creating netapp-harvest user ... OK
Installing : netapp-harvest-1.6-1.noarch 1/1
### Autostart NOT configured. Execute the following statements to configure autostart:
sudo systemctl daemon-reload
sudo systemctl enable netapp-harvest
### Configure your pollers in /opt/netapp-harvest/netapp-harvest.conf.
### After pollers are configured start netapp-harvest by executing:
sudo systemctl start netapp-harvest
Verifying : netapp-harvest-1.6-1.noarch 1/1

Installed:
netapp-harvest.noarch 0:1.6-1

Complete!
[root@az-nlsrvup-smo01 tmp]# rpm -q netapp-harvest
netapp-harvest-1.6-1.noarch.rpm netapp-harvest_1.6_all.deb netapp-harvest-1.6.tgz netapp-harvest_1.6.zip
[root@az-nlsrvup-smo01 tmp]# rpm -q netapp-harvest
netapp-harvest-1.6-1.noarch.rpm netapp-harvest_1.6_all.deb netapp-harvest-1.6.tgz netapp-harvest_1.6.zip
[root@az-nlsrvup-smo01 tmp]# rpm -q netapp-harvest-1.6-1.noarch.rpm
package netapp-harvest-1.6-1.noarch.rpm is not installed
[root@az-nlsrvup-smo01 tmp]#

 

Need your direction soon on this. 

 

 

Try the NEW Knowledgebase!
NetApp KB Site
Forums