Data Infrastructure Management Software Discussions

vFiler not discovered after migration

Hi there

DFM 5.2, ontap 8.1.4 7-Mode

We have recently migrated a vFiler from one controller to another, using the commandline "vfiler migrate start..." because the DFM GUI wasn't working...

The "vfiler migrate" is now done, and we have removed the old physical controller entry from the DFM GUI, and with it, the vfiler entry as DFM was still thinking that the vfiler was located on the old controller, and was showed as "offline/stopped"

Now we have the vfiler running on the new system, but DFM cannot discover the vfiler... 😞

We have even tried "dfm vfiler add all -H controller" which only adds old deleted vfilers which are shown as offline/stopped, and is then removed by DFM after a few minutes..  but the vfiler in question does not show up...

How do I make DFM discover the vfiler ?

Is there a way to "force" DFM to register the vfiler?

We have also tried to do a "dfmpurge" on the database, which didn't solve the problem...

We have verified that the dfm options discovervfilers is on, and vfilermonitorinterval is also set at 30 mins.  but it has been several days now, and it haven't shown up yet...

I hope someone can help me out here ?




Re: vFiler not discovered after migration


Can you check for any error in dfmmonitor log wrt this vFiler that is migrated?

Also, is the old vFiler still showing up in the mark deleted object list?



Re: vFiler not discovered after migration


We didn't do the vfiler migration from within DFM, we did it on the destination controller from commandline, because DFM complained...  the command is: "vfiler migrate start...", then when the snapmirrors are in sync "vfiler migrate complete..." all this went down with no problems.

We then turned off the source controller (old system), we then removed the physical controller from within DFM (which was offline).  This also removed the vfiler which was previously on the controller.

Now DFM cannot discover the vfiler...  and I belive it is marked as deleted (maybe because it still thinks it resides on the old powered down system).

When we do a "dfm vfiler add all -H newcontroller" it complains about the vfiler is marked as deleted...

We have then tried a dfmpurge.exe, but the same error perssists...


Re: vFiler not discovered after migration

Here is the output from the dfm vfiler add all -H controller

Error: Can't add vFiler vfiler.domain (101010) because hosting storage system is not being monitored.

The vfiler with the ID 101010 is marked as deleted...


Re: vFiler not discovered after migration


SO your vFiler is marked as deleted and you are not able to discover the same named vFiler from the new controller.

old vFiler is just marked deleted but not completely removed from DFM. You can do this small exercise to see if removing this marked deleted vFIler from dfm db completely will allow you to discover the vFiler from new controller:

Note: you need to stop dfm services and restart in doing this operation. If its production, you might want to get a small planned maintenance window to do this operation.

1. Say vfiler 101010 is marked as deleted as in your case.

2. Execute the following commands:

    dfm service stop

    dfm service start sql

    dfm host delete -f <vFiler id (101010 in your case)>

    dfm service start.

3. Now vFiler 101010 should not be listed under dfm vfiler list -a command as it is no more in DFM db.

4. Now the vFiler in the new controller should get discovered.

Let me know if this works.



Cloud Volumes ONTAP
Review Banner
All Community Forums