Autosize error when configuring max size.

Hi All

I received the following System log entries:

[nakg01-01: ems.engine.inputSuppress:info]: Event '' suppressed 59 times since Fri Jul  6 10:16:39 EST 2012

[nakg01-01:]: Unable to grow volume 'estore_bbox_s_01' to recover space: Volume cannot be grown beyond maximum growth limit

However the volume is not running out of space. Following are the volume details:

nakg01-01> df -h /vol/estore_bbox_s_01

Filesystem               total       used      avail capacity  Mounted on

/vol/estore_bbox_s_01/      423GB      280GB      142GB      66%  /vol/estore_bbox_s_01/

/vol/estore_bbox_s_01/.snapshot       46GB      234MB       46GB       0%  /vol/estore_bbox_s_01/.snapshot

The existing autosize setting on the volume are as follows:

vol autosize /vol/estore_bbox_s_01

Volume autosize is currently ON for volume 'estore_bbox_s_01'.

The volume is set to grow to a maximum of 564 GB, in increments of 24064 MB.

When I tried to increase the maximum growth limit I get the following error:

nakg01-01> vol autosize /vol/estore_bbox_s_01 -m 600g -i 10g on

vol autosize: Specified volume maximum size is too small and must be greater than current size.

And now autosize is set to OFF on the volume and I get the above error when trying to turn it back on.

It does not seem to matter what size I try to make the maximum growth limit, I still get the same error and autosize remains disabled.

This volume is on the same aggregate as other volumes which reported the same condition but have not given me an issue when increasing the maximum growth limit.

This is a Thin provisioned Flexvol on a vfiler with Dedupe enabled.

We are running NetApp Release 8.0.3 7-Mode: Thu Mar 29 22:27:55 PDT 2012

Does anyone have any suggestions on what I can do to resolve this issue and get autosize enabled on the volume again?

Kind Regards


Re: Autosize error when configuring max size.

I am seeing the exact same error with 2 volumes at a customer site.  They are on 8.0.2.  When I tried to turn autogrow back on with the exact same settings I received the same error.  However, I increased the size by 1 GB on both of the volumes for the maximum autogrow size and was able to turn it back on.

Try this: nakg01-01> vol autosize /vol/estore_bbox_s_01 -m 601g -i 10g on

See if that makes a difference for you...I'm not sure why that is the case since I wasn't running out of space and the size of the volume was considerably smaller than the configured autogrow max at the time.

Re: Autosize error when configuring max size.

Thanks John

This did the trick. Interestingly, it still gave the same error after increasing max size by 1 but leaving the increment at what it originally was (23.5G). I then tried changing the increment to 10G with the max increased by 1, and it worked. I then tried to increase the increment to 15 then 20G and that worked also. However, when I tried to change the max size to anything else, it failed.

Now I am not sure why the increment was at 23.5 (I don't remember ever setting it to this and I always try to not leave it at whatever NetApp defaults to, though maybe I missed this one). We recently (a couple of months ago) upgraded from 7.3.2 to 8.0.3 and I wonder if anything changed at this stage?

I have found another volume that had the same issue and was able to successfully set autosize max to 1G more and increment of 10G.

I rarely let autosize manage the size of volumes, choosing to manually increase the size rather than risk autosize not working. I wonder if this might have something to do with the error occurring? I thought maybe I increased the size by more than 120% of the original, which is the autosize maximum, but checked and found that not to be the case.

For the moment this has fixed my logs being filled with autosize errors, but if I can't find a workaround before the volumes grow to the maximum set now, I will have an issue again, so any other suggestions from anyone will still be appreciated.

Kind Regards


Message was edited by: Scott Berry EDIT:     Ok this didn't fix the log issue. I am now once again getting the following error, even though the volume is still no where near full: Tue Jul 10 12:28:38 EST [nakg01-01:]: Unable to grow volume 'estore_bbox_s_01' to recover space: Volume cannot be grown beyond maximum growth limit

Re: Autosize error when configuring max size.

Interesting.  After modifying the autogrow setting I didn't see any more errors for the next 3 or 4 hours and then I did an ONTAP upgrade to 8.1 and haven't seen any autogrow errors since the upgrade either.  Maybe it's and issue that is corrected in 8.1. Not much of a reason to upgrade though.