Accepted Solution

Cifs server creation in cluster mode

Hi all,

I have tried to setup a cifs server on a cluster mode ONTAP 8.1. Everything goes well, I create the vserver and execute cifs setup, then I create some shares.

The problem comes when I attempt to connect to my shares via a windows client (2008 R2). It keeps asking for a user name and password. I can input whatever password I want, it keeps telling me "System Error 86"

my share is set to "everyone/full control"

I have tried everything I could, now I am asking you guys if you have any clue on what I could have been configuring wrongly.

In the cifs setup wizard, I choose to use "file " for authentication and it asked me to create a UNIX user which i called "root" with id 0, so far so good but I never had the opportunity to give this "root" user a password.

If I select LDAP, it doesn't work either, my cifs shares are not seen on the windows client.

help would be greatly appreciated

yves l

Re: Cifs server creation in cluster mode

Is the Vserver security style ntfs?  Is the volume security style target ntfs? 

vol show volname -inst 

vserver show -inst

Re: Cifs server creation in cluster mode

Your volume needs to be NTFS, but you still need a basic username mapping (this is currently a known bug), so you should add that too.

Also you might need to define an export-policy.

Try re-creating your vServer by using the System Manager 2.0.1, this generally works pretty well


Re: Cifs server creation in cluster mode

My volume security style is NTFS. I have used the default export-policy and still no luck.

I really don't know what's going on here?


Re: Cifs server creation in cluster mode

You have a unix user and group defined and a default unix user for the vserver? There is a really good kb on cifs I will look up later. Following it covers cifs setup. Without a default unix user or explicit mappings cifs won't work. A "feature". Same issue in either 7-mode or cluster-mode.

Re: Cifs server creation in cluster mode

Ok I have found the culprit. The permissions were not set correctly on the root volume of the vserver,that's why I had these authentications problems.

thanks for your help guys