Data ONTAP Discussions

Error When Trying to Add NFS Export in FilerView

I'm trying to setup an export for NFS using FilerView, but when I click on Add Export or Configure Export I get this Java error. Any ideas? zapi query failed
 at netapp.fv.nfs.Export.refresh(
 at netapp.fv.nfs.wizard.BasePage.getInfo(
 at netapp.fv.nfs.wizard.BasePage.getPageContent(
 at netapp.fv.servlets.WizardServlet.getBody(
 at netapp.fv.servlets.WizardServlet.service(
 at javax.servlet.http.HttpServlet.service(
 at netapp.servlet.NetappRunner.execute(

Re: Error When Trying to Add NFS Export in FilerView

Whenever a customer has a java issue, I always ask they upgrade or install the latest java at (or anywhere you trust to get the latest) and 99.9999% of the time these errors go away.

Also, FilerView is great for many things, but I still prefer to manually edit /etc/exports...anyone who has ever been bit by a gui issue (rc file more commonly when network is modified from filerview) tends to edit the files... with snapshots and backups copies made of the files you are ok, but I still recommend editing the file.

Re: Error When Trying to Add NFS Export in FilerView

I checked the Java site and I am running the most current version of Java. When I first got the error, I thought it might have been my machine since I am running Vista and IE 8. But I tried the page in Firefox and Chrome and it still didnt work. So I tried it from an XP machine running IE7 and up to date Java and still get the error. I had used the commands to get things done from time to time but wanted to get the GUI working too. I see that there maybe solutions on the NetApp NOW site, but after providing our System ID last week, our account is still stuck on Guest Access, meaning we basically can't see anything.

Re: Error When Trying to Add NFS Export in FilerView

Do any other Java pages have the same issue? If you click on other widgets? If not the java client, the other typical fix is to push ONTAP back onto the controller. If the java files are corrupt...just push the same version already running and that often fixes java issues (ndmp, filerview, etc.)... sometimes a reboot is needed as well but often pushing the files will fix the issue.

Re: Error When Trying to Add NFS Export in FilerView

Yes. Two pages under the NFS section through the error above. But in other parts of FilerView, Jave will pop up a Window saying it has thrown an exception, and Internet Explorer will lock up. We will look into pushing ONTAP back onto the controller. Thanks!

Re: Error When Trying to Add NFS Export in FilerView

I get all sorts of java messages when trying to work in FilerView. I think they happen when the filer is busy as the functions work without problem at other times. Sometimes F5 will fix the issue but it always worries me when things start going strange for no good reason. Recommend you get into CLI as it is the future of administration...

Have taken this from the NetApp foundation course notes. ~ Not going to type this again....

/etc/exports File

As a system administrator, you want to control how NFS clients access files and directories on a storage appliance. Exported resources are those that you make available to hosts. NFS clients can mount only resources that have been exported from a storage appliance licensed for NFS.

There are two ways to export resources:

  • For persistence across reboots, specify resources to export in the /etc/exports file; then execute the exportfs -a command to make the changes effective immediately.
  • For temporary access, use the exportfs command to export resources not specified in the /etc/exports file or to export resources specified in the file but with different access permissions

Add entries to the /etc/exports file for each directory you want to export. Entries specify the full path to a directory and options. The full path name must include /vol, as in /vol/vol0/home. The export specifications restrict access using the following options:

  • root=list of hosts, netgroup names, and subnets
  • rw=list of hosts, netgroup names, and subnets
  • ro=list of hosts, netgroup names, and subnets

Re: Error When Trying to Add NFS Export in FilerView

I've seen this error/bug when the NFS license has expired. If the license is expired renewing it will fix this issue.