How to fix SME when it shows Exchange storage groups as invalid?

Hi Everyone,

Does anyone know how to re-associate SnapManager for Exchange back with the storage groups - it doesn't seem possible using the configuration wizard?

It's a little bit more complicated because our Exchange server was initially setup & configured correctly with SnapDrive and SnapManager (we have 1 LUN for logs + snap info, and 1 LUN for databases) - but then we created more storage groups and folders on the LUN/disks using Exchange System Manager & renamed the original storage group disk folder too. The drive letter mappings to the LUNs are the same, but the folder structures on the disks have been re-organised with folders containing the various databases and logs.

Now we have all of our storage groups & logs nicely structured on our iSCSI LUNS, but unfortunately SME cannot see them. And when I run the wizard it only allows me to move 1 storage group to 1 LUN (I can't select all SGs and associate them with the same LUN/drive letter). It's a 1to1 mapping.

And if I try to perform a snapshot, it shows my storage groups as "invalid".

I've already had 1 disaster with SnapManager this week, so I don't want to attempt to move 1 storage group at a time using the wizard to then find out it's duplicated/deleted the other existing SGs on the LUN!!

Does anyone know the correct way to fix this?



Re: How to fix links between SME and storage groups?

If it helps anyone, SME says "invalid" and displays a little red "!" next to each storage group.

But the paths it shows for each storage group, to the logs, stream and databases are correct for each storage group!

So it can see the LUNs, it can see the storage groups and where the logs/databases/streams are, but it still says "invalid" for each one.

I am getting desperate...

Re: How to fix links between SME and storage groups?

Problem solved.

It seems SME was reporting the storage groups as invalid as we'd created a 2nd storage group and put it's databases/mailbox stores on the same LUN as the 1st storage group - and SME doesn't support multiple database from different storage groups on the same LUN. All databases on a LUN have to belong to the same storage group.

Simple misconfiguration in the end.