Data ONTAP Discussions

In NetApp Release 8.3.1P1 , CIFS Not Joining AD Domain

Facing issues while connecting AD with Netapp when smb1 is disabled and smb2 is enabled.

 

After setting 

set -privilege advanced , i am unable to run the below command.

 

qasvm::vserver cifs*>  vserver cifs security modify -vserver qasvm -smb1-enabled-for-dc-connections false -smb2-enabled-for-dc-connections true

Error: invalid argument "-vserver"

 

The above command is valid for Netapp version 9. I am using NetApp Release 8.3.1P1 version .

Further tried executing the below ommand to enable the smb2 and disable smb1

vserver cifs options modify -vserver vserver_name smb_version true

 

This command exceuted successfully, but could not able to connect still.. Any help please.

 

Thanks

Siddharth

 

 

 

Thanks

Siddharth

4 REPLIES 4

Re: In NetApp Release 8.3.1P1 , CIFS Not Joining AD Domain

Refer to this KB: https://kb.netapp.com/app/answers/answer_view/a_id/1000201

Specifically:

 

Symptom
It is possible to disable SMB 1.0 starting in ONTAP 9.1P8 and 9.2.  
It is also possible to disable in 7-Mode filer in 8.2.5. 
There is no option to completely disable SMB 1.0 in Data ONTAP 7-Mode before 8.2.5, clustered Data ONTAP (CDOT), or versions of ONTAP prior to 9.1P8 or 9.2.
 

 

Re: In NetApp Release 8.3.1P1 , CIFS Not Joining AD Domain

Thanks for the info,  i tried the below command but still it failed.

 

// Login to cluster level

ssh admin@172.22.0.100

nacl01::> set -privilege advanced

nacl01::*> cifs security modify -vserver qasvm -smb1-enabled-for-dc-connections false -smb2-enabled-for-dc-connections true

Error: invalid argument "-smb1-enabled-for-dc-connections"

 

nacl01::*> exit

 

// Login to vserver level

ssh vsadmin@172.22.0.235

qasvm::> cifs security modify -smb1-enabled-for-dc-connections false -smb2-enabled-for-dc-connections true                

Error: invalid argument "-smb1-enabled-for-dc-connections"

 

I guess the above command is valid for Netapp 9.1 

I am using NetApp Release 8.3.1P1 and seems the above command not valid for this version.  Any other  help would be realy helpful for me. 

Is there any patch that we can apply and we can able to join smb2? or we have to upgrade our Netapp from 8.3 to 9.1?

 

Thanks

Siddharth

 

 

Thanks

Siddharth

Re: In NetApp Release 8.3.1P1 , CIFS Not Joining AD Domain

Did you read the last post?

Symptom
It is possible to disable SMB 1.0 starting in ONTAP 9.1P8 and 9.2
 
you are on 8.3. It will not work
 you would have to upgrade to ONTAP 9.1P8 or higher
 or
 reenable smb1 in the environment

Re: In NetApp Release 8.3.1P1 , CIFS Not Joining AD Domain

Thanks, will check after upgarding to ONTAP 9.1P8 or higher

Forums