Subscribe
Accepted Solution

Issues with QLogic CNA (1140-R6)

Forgive me, I am a network engineer. I am trying to setup an HA pair of FAS6280s running 8.1.4 7-Mode. I have installed QLogic CNAs (1140-R6) and they have been recognized by the FAS. However, I cannot get the link to come up (see below):

 

Slot: 3b Description: Fibre Channel Target Adapter 3b (QLogic CNA 8112 (8152) rev. 2)

Status: LINK NOT CONNECTED

Host Port Address: 0x000000

Firmware Rev: 5.5.2 MPI

Firmware Rev: 1.40.5 PHY

Firmware Rev: 1.8.0

FC VLAN ID: 0

FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)

FC Portname: 50:0a:09:88:9f:b0:d1:c8 (500a09889fb0d1c8)

FC Packet Size: 2048

Data Link Rate: 0 GBit

Adapter Type: Local

Fabric Established: No

Connection Established: Loop

Mediatype: ptp

Partner Adapter: None

Standby: No

Target Port ID: 0x106

Switch Port: Unknown

Physical Link Rate: 10 GBit

Physical Link Status: LINK UP

 

 

Anybody be able to help me out?

Re: Issues with QLogic CNA (1140-R6)

[ Edited ]

Hi there,

 

Can you please post the output of "ucadmin show -c" and post details of the cable being used by the adapter as well as details of the device on the other side of the link?

 

I suspect the card might be in FC mode, in which case ucadmin modify will change status after a reboot.

 

The X1140 only supports TwinAx cables (not optical SFPs) and only supports the following models

 

  • X-SFP-H10GB-CU1M-R6 (Cisco TwinAx 1M, V02 or later)
  • X-SFP-H10GB-CU3M-R6 (Cisco TwinAx 3M, V02 or later)
  • X-SFP-H10GB-CU5M-R6 (Cisco TwinAx 5M, V02 or later)
  • X6566B-1-R6 (NetApp OEMed TwinAx cable 1M)
  • X6566B-3-R6 (NetApp OEMed TwinAx cable 3M)
  • X6566B-5-R6 (NetApp OEMed TwinAx cable 5M)

Hope this helps!

 

Re: Issues with QLogic CNA (1140-R6)

The other side of the connection is a Cisco 5k with FCoE configured.

 

FAS adapters:

 

FAS6280A> fcp show adapter
Slot: 5a
Description: Fibre Channel Target Adapter 5a (QLogic CNA 8112 (8152) rev. 2)
Adapter Type: Local
Status: LINK NOT CONNECTED
FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)
FC Portname: 50:0a:09:83:9f:b0:d1:c8 (500a09839fb0d1c8)
Standby: No

Slot: 5b
Description: Fibre Channel Target Adapter 5b (QLogic CNA 8112 (8152) rev. 2)
Adapter Type: Local
Status: LINK NOT CONNECTED
FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)
FC Portname: 50:0a:09:84:9f:b0:d1:c8 (500a09849fb0d1c8)
Standby: No

Slot: 4a
Description: Fibre Channel Target Adapter 4a (QLogic CNA 8112 (8152) rev. 2)
Adapter Type: Local
Status: LINK NOT CONNECTED
FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)
FC Portname: 50:0a:09:85:9f:b0:d1:c8 (500a09859fb0d1c8)
Standby: No

Slot: 4b
Description: Fibre Channel Target Adapter 4b (QLogic CNA 8112 (8152) rev. 2)
Adapter Type: Local
Status: LINK NOT CONNECTED
FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)
FC Portname: 50:0a:09:86:9f:b0:d1:c8 (500a09869fb0d1c8)
Standby: No

Slot: 3a
Description: Fibre Channel Target Adapter 3a (QLogic CNA 8112 (8152) rev. 2)
Adapter Type: Local
Status: LINK NOT CONNECTED
FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)
FC Portname: 50:0a:09:87:9f:b0:d1:c8 (500a09879fb0d1c8)
Standby: No

Slot: 3b
Description: Fibre Channel Target Adapter 3b (QLogic CNA 8112 (8152) rev. 2)
Adapter Type: Local
Status: LINK NOT CONNECTED
FC Nodename: 50:0a:09:80:8f:b0:d1:c8 (500a09808fb0d1c8)
FC Portname: 50:0a:09:88:9f:b0:d1:c8 (500a09889fb0d1c8)
Standby: No

 

Transceiver:

 

Ethernet1/4
transceiver is present
type is SFP-H10GB-CU5M
name is CISCO-MOLEX
part number is 74752-9047
revision is 07
serial number is MOC15181327
nominal bitrate is 10300 MBit/sec
Link length supported for copper is 5 m
cisco id is --
cisco extended id number is 4

 

Thanks in advance!

Re: Issues with QLogic CNA (1140-R6)

This is resolved. It was a configuration change on the fabric switch side. I needed to change the Admin port mode under the VFC configured on the 5k to "F".

 

cisco5k(config)#interface vfc XXX

cisco5k(config-if)#switchport mode F