Data ONTAP Discussions

Issues with SRM & Snapmirror

We are testing using DR failovers with VMWare SRM.

We seem to be able to perform the recovery okay 1 way, but when we try and do the re-protect, it fails saying no snapmirrors exist.

snapmirror status - shows unitialized on the new destination, and the old source still intact.

snap list - shows only the last snap on each volume that we are doing this on, on the destination, which after the recovery is now the source.

Volumes, and associated luns are online.

This is the case, and also, the entries in snapmirror.conf have been removed.

I can add them back in, and re-initialize the snap, but this is a 2Tb vol x 2 involved,and do not want to do this every time.


Re: Issues with SRM & Snapmirror


Are you talking SRM 4 or SRM 5?



Re: Issues with SRM & Snapmirror


5.0.1 with the NetApp FAS SRA v2.0

Re: Issues with SRM & Snapmirror

Re-protection should work automatically.

That said, if you re-intialize SnapMirror, the baseline is not transferred as long as there is a common snapshot at both ends.

Re: Issues with SRM & Snapmirror

It is only on the re-protect where we get the problems.

there is a snapshot at the current destination side for both volumes, but nothing on the source side.

Re: Issues with SRM & Snapmirror

That's odd - you should have at least one snapshot at the source acting as a baseline for SnapMirror.

Re: Issues with SRM & Snapmirror

I know - this is why I am confused, and concerned.

Obviously the destination was the source at the start of the failover, and that is where the snaps reside, but nothing exists on what was the destination, and will be the source as part of the re-protect.

Re: Issues with SRM & Snapmirror

For SnapMirror transfer you need snapshots at both ends, so apparently one 'disappeared'

Something is seriously going wrong - I would open support case.

Re: Issues with SRM & Snapmirror

I do have a case opened, and I have just been asked to an initialize on what is the destination.

Have sent in snapmirror logs, nsanity reports, screen captures, and just been asked to do this, was hoping someone had seen it before, and could help out.

Re: Issues with SRM & Snapmirror

Update - NetApp advised adding snapmirror entries on both sides for snapmirror.conf.

Did this, re-initialized, and waited.

Once all data snapped, we then did the re-protect and it worked.

We then tried the fail bacl, which worked, but whilst doing that, it deleted the snaps from what was the source, and was going to be the destination.

It has left both sides of the snap un-unitialized.

One thing I did notice was that the luns are still online, and mapped on both sides !