Data ONTAP Discussions

ONTAP 8.1 / Deduplication Issue

Hi All,

Recently upgrade a FAS6210 array to ONTAP 8.1 GA. Client has several volumes 16TB +, so this was a big need for them.

Aggregates are 64-bit so dedupe limitation for this platform is 70 TB (max volume size).

When I go to enable deduplication on any of these volumes (and even some that are much smaller), I receive the message "Operation Not Configured." This error occurs in both System Manager and the CLI.

I know that deduplication is no longer a "licensed feature" and is built into the ONTAP core, but is there an option someplace that I'm missing?

I have a case open that's awaiting escalation but reaching out everyone here as well



Re: ONTAP 8.1 / Deduplication Issue

I ran into this error as well using the DataOnTAP PowerShell cmdlets. I was attempting to set the SIS settings before enabling SIS on the volume. Now, the command I run is this:

get-NaVol x | enable-NaSIS | Set-NaSIS -schedule auto | Start-NaSIS

Hope that helps.

Re: ONTAP 8.1 / Deduplication Issue

Hi Paul,

Thanks for the input. Unfortunately, I get the same error as I've been getting all along...

PS C:\WINDOWS\system32\WindowsPowerShell> get-NaVol vol_atldata02_litigation_rep | enable-NaSIS | Set-NaSIS -schedule auto | Start-NaSIS

Enable-NaSis : Operation is not configured

At line:1 char:54

+ get-NaVol vol_atldata02_litigation_rep | enable-NaSIS <<<<  | Set-NaSIS -schedule aut

o | Start-NaSIS

    + CategoryInfo          : InvalidOperation: ( [Enable-N


    + FullyQualifiedErrorId : SisEnableFailed,DataONTAP.PowerShell.SDK.Cmdlets.Sis.Ena


Re: ONTAP 8.1 / Deduplication Issue

Hi Trey,

I had same problem, try to put offline the volume and then back-online.

it's worked for me.

Re: ONTAP 8.1 / Deduplication Issue

thanks for the suggestion, but this did not work for me.

I've had a case open with NetApp support since the issue started and still have no resolution. I have a feeling this one may go to the ONTAP team.

We shall see.

Re: ONTAP 8.1 / Deduplication Issue

Still dont have resolution from netapp its almost 17 days ...crazy .

Re: ONTAP 8.1 / Deduplication Issue

Hi Trey

It happened to me too ..did you hear back from NetApp?

Re: ONTAP 8.1 / Deduplication Issue


just a guess, I think SIS needs a nearstore license to work?

Have you tried to enable nearstore feature if it's "off" at the moment? >options licensed_feature.nearstore_option.enable


Re: ONTAP 8.1 / Deduplication Issue

Problem solved... a failover for the controller helped to restore the a-sis feature. Yes, Iwas lucky, since I have an HA configuration that allowed me to failover to the second node.

Anyway, NetApp is aware of this issue: