Data ONTAP Discussions

Problems with NFS share on Netapp?

In dolphin I can see all of the files in my netapp share, but when I try to open them, I get these sort of errors.

Could not connect to host

That's using a fedora VM. I have a CentOS VM that shows my volume as being vol⁄myvol. Notice that the slash is farther forwards than a normal forward slash. When trying to open the folder it tells me the location /vol(weird symbol) doesn't exist. I tried replacing the weird slash with a normal forward slash, and it tells me /vol/myvol doesn't exist.

After a while I am now able to access files on the fedora VM, but the CentOS VM still tells me the volume doesn't exist.

I've tried to mount the VM like so

mount -t nfs /mnt/netapp

and the mounting process hangs for a long time, and then (sometimes) times out.

I think something is wrong with the way my Netapp simulator is set up. I'm using version 7.3.6 of the Netapp simulator. 

When I run the command exportfs the simulator tells me

/vol/myvol       -sec=sys,rw,nosuid

And when I use the command qtree status it tells me

Volume   Tree     Style Oplocks  Status

-------- -------- ----- -------- ---------

myvol              unix  enabled  normal

Does anyone have any ideas as to what I could do to be able to reliably work with the files on my Netapp NFS share?


Re: Problems with NFS share on Netapp?

What does showmount -e show? It works in my centos vm. Might be a network issue on the vmnet

Re: Problems with NFS share on Netapp?

[fedora@localhost ~]$ showmount -e

clnt_create: RPC: Program not registered

[centos@localhost ~]$ showmount -e

clnt_create: RPC: Program not registered

netapp-sim> nfs

Use of "nfs" by itself is deprecated, please use "nfs status"

The following commands are available; for more information

type "nfs help <command>"

diag                nsdb                on                  stat

help                off                 setup               status

NFS server is running.

Oh and I forgot to mention. I can access all of the volumes from my windows machine using a CIFS share.

It could be a network problem. I have the simulator set to be using a bridged adapter, and I changed the MAC address of the simulator to match the VM that the simulator is running on. These allowed me to communicate with the Netapp simulator just fine, until now. I don't know what the difference is between bridged adapters and nat, but I don't think nat is set up on my network. I've always been told to use bridged adapters, and until I switch any of my VMs to a bridged adapter, the VM can't see anything else on the network.

Re: Problems with NFS share on Netapp?

I have the same problem on a real CDOT system. I have two different vservers both have NFS started, on one I get RPC error.

Re: Problems with NFS share on Netapp?


showmount -e

you should see your exports then. Also check "options.nfs" and make sure that UP is disabled and TCP is enabled (as UDP has a nasty bug on some OnTap versions). Try mounting explicitly with "mount -o proto=tcp /mnt/..."


Re: Problems with NFS share on Netapp?

In that case check for differences in the following areas

- export policies

- volume security styles

- vserver default users for NFS

- vserver name mappings, local-users and local-groups