Replication issues

please i'm having issues replicating to my DR filer. this was what i got when i tried running a snapmirror status command:

        Unknown        -          Pending with restart checkpoint (at 138 GB)

when i issue a vol status command i get the following:

" raid_dp, flex  invalid"

and when i try initiating a snapmirror, i get the following:

Transfer aborted: could not read from socket. volume not online

please i need help on how to resolve this issue. thanks in anticipation

Chiedozie Eguzozie.


Re: Replication issues

unknown status comes when the destination volume is offline/restricted.
The status 'Pending with restart checkpoint' comes when transfer got aborted.

As the destination volume is not online, I think this must be base transfer where destination volume remain restricted.

what do you mean by 'i try initiating a snapmirror' ? what is the command you used ?

Re: Replication issues

i initiated the snapmirror by using the command "snapmirror initilize -S" to run the snapmirror and an error returned saying " transfer aborted: cannot connect to socket". meanwhile the connectivity issue between source n destination filers are both intact(both can reach each other).

how do i resolve this pls??

Re: Replication issues

try with 'snapmirror update destination_volume'. This may trigger the transfer right from the start ie., re-transfers 138 GB (I think this happens for SAN volumes after network outages (packet loss)).

If this do not change the status, try manually aborting the previous action with 'snapmirror abort destination_volume', then run 'snapmirror update destination_volume'

Re: Replication issues

and one more thing when i am checking out its status its showing me invalid

on destiantion filer:

           vol status volume

         Volume State           Status            Options

                 volume     restricted   raid_dp, flex


                Containing aggregate: 'agg2'

when i am updating snapmirror relation its throwing error:

               transfer aborted:volume not online.

that's also part of the issue too. any resolution advise will be most welcome. thanks

Re: Replication issues

have you tried running 'snapmirror abort dest_vol' and then 'snapmirror update -S ' ?

If this too won't affect the status, then run 'vol online volume_name' ;

i) if the volume was left in inconsistent state, destroy the destvol and recreate it and follow the entire process again.

ii) if it comes online (quite unusual), then you can run update.

In general, while performing base transfer, it's must to ensure zero network outage.

and invalid says you have no valid file system in the volume