Snap Restore problem

Hi all

I am trying to run a single file "Snap Restore -t file" command on my NetApp Filer from a command-line inside the filer.

I have both a CIFS volume and a NFS volume.

Snap Restore works fine when I run the commands inside my CIFS volume.

But when I use the Snap Restore command inside my NFS volume, I get the messsage "File does not exist in snapshot."

But if I browse my Filer (using WinSCP) I can see the file, I am trying to restore, inside the ~snapshot folder?

The NFS volume is used for my VMware server files.

These are the details:

NFS volume name is: tknfsdata_01

The path to the file I am trying to restore is: /vol/tknfsdata_01/vmfs/volumes/Datastore1/tkweb/tkweb.vmx 

                                                                 (This path has been copied from the WinSCP browser window)

My command:

TKNAS1> snap restore -t file -s nightly.0 /vol/tknfsdata_01/vmfs/volumes/Datastore1/tkweb/tkweb.vmx

WARNING! This will restore a file from a snapshot into the active
filesystem.  If the file already exists in the active filesystem,
it will be overwritten with the contents from the snapshot.

Are you sure you want to do this? y

You have selected file /vol/tknfsdata_01/vmfs/volumes/Datastore1/tkweb/tkweb.vmx, snapshot nightly.0

Proceed with restore? y

snap restore: File does not exist in snapshot.

I suspect that my path is wrong, but I can´t see where??

Are there any commands in ONTAP 7.3.1 that can be used to browse the filer, like "cd" or "ls -l"???

Best regards

Jens Nielsen

Re: Snap Restore problem


Solved it :-)

The command shold be:

     TKNAS1> snap restore -t file -s nightly.0 /vol/tknfsdata_01/tkweb/tkweb.vmx

and NOT:

     TKNAS1> snap restore -t file -s nightly.0 /vol/tknfsdata_01/vmfs/volumes/Datastore1/tkweb/tkweb.vmx

..because the snapshot files are not present until you are located inside the "Datastore1"- folder.

Sorry for your time.  Maybe it can help others in same situation.

Best regards