SnapDrive creating wrong sized LUNs


I've been experimenting in my virtualized lab today and I realized that that SnapDrive (ver 5.1) which i've installed on Windows 2003 is reducing defined disk size by 10-20%. For instance, I would create a 500MB volume, turn snapshot reserve off, create a share on top of it and tell SnapDrive to create a... say, 450MB dedicated LUN.

On NetApp side, everything looks the way it should - LUN size, mapping, state. SnapDrive reports the same when I check the Disk menu (path, size, initiator, reserve, etc).

But in reality, 13% gets lost somewhere and only a 390MB local disk pops up.

On the other hand - If I create a LUN manually, map it by "hand" and discover the new disk through Rescan Disk in Computer Management, I can format it to the full capacity. No problem.

I haven't made any configuration changes in my "lab" in over a year... What could be wrong with SnapDrive?



Re: SnapDrive creating wrong sized LUNs

Hi Igor,

This might be a silly suggestion, but have you considered the impact of using GPT instead of MBR? GPT reserves a small portion of the disk. Especially on a small LUN (500 MB in this case), you would certainly notice that.

Regards, Bjorn

Re: SnapDrive creating wrong sized LUNs

Have you looked at DiskPart or similar to see the partition layout? Can you expand the LUN you've created at all?

When you run through the create LUN wizard in SnapDrive, it just calculates a LUN figure, it won't make full use of the usuable space (for various reasons). Can you manually go in and select 450 MB when creating the LUN in SnapDrive (on the page you select the drive letter)?

Re: SnapDrive creating wrong sized LUNs

Hi Bjorn,

It seems the reduction is always present and notable, regardless of the disk size.

Re: SnapDrive creating wrong sized LUNs

I've tried extending it through DiskPart, can't be done.

Yes, I've chosen all parameters carefully. Still, even though SnapDrive reports "success" and displays info saying there's a full-sized LUN present - the actual size is smaller. Weird.

Re: SnapDrive creating wrong sized LUNs

Hello all,

I just tried it on our demo-machine. Everything works fine.

This is probably a simulator bug or something... :-)

Thanks for your efforts!