Subscribe

Snapshot in use, and cannot delete

I am trying to delete a snapshot, but getting following message:

Error: command failed: Snapshot is in use

 

I used the option: -ignore-owners true -force true

still the same error.

 

No Snapmirror, snapvault or clone associaetd with the volume

 

Any idea how to delete it?

Re: Snapshot in use, and cannot delete

might be busy snapshot issue

check this

https://kb.netapp.com/support/s/article/ka31A00000013dmQAA/how-to-use-lun-snap-usage-s-when-deleting-busy-snapshot-copies?language=en_US

thanks

 

Jeff

Cannot find the answer you need?  No need to open a support case - just CHAT and we’ll handle it for you.

Re: Snapshot in use, and cannot delete

hello, have you resolve the issue? i have the same problem too,

Re: Snapshot in use, and cannot delete

We are still having the same problem too. Have tried to force delete the snaps with no sucess. Any further help appreciated.

 

::*> snap delete -vserver tur-nas1 -volume tur_nas1_streamv19_content -snapshot SP_2_1213666_7626_1460597749 -foreground true -force true -ignore-owners true

Error: command failed: Snapshot copy "SP_2_1213666_7626_1460597749" of volume "tur_nas1_streamv19_content" on Vserver "tur-nas1" has not expired or is locked. Use the "snapshot show -fields owners, expiry-time" command to view
the expiry and lock status of the Snapshot copy.

 

 

::*> snapshot show -fields owners,expiry-time -vserver tur-nas1 -volume tur_nas1_streamv19_content
vserver volume snapshot owners expiry-time
-------- -------------------------- ---------------------------- -------------- -----------
tur-nas1 tur_nas1_streamv19_content SP_2_1213666_7626_1460597749 "volume clone" -
tur-nas1 tur_nas1_streamv19_content test_snapshot_ian - -
tur-nas1 tur_nas1_streamv19_content snapmirror.02422c1b-4daf-11e4-8a7c-123478563412_2147484763.2018-02-28_143000