Data ONTAP Discussions

cDOT NFS - .snaphot directly automounting

Hello Guys,

 

I have seen a strange behaviour with Netapp Cluster Mode, when we do a NFS export to a unix server they can moun it correclty no issues.

After sometime when a new snapshots is created the Unix is showing up all the snapshots, as they are directly mounted on the system:

 

ubuntu@vx910:~$ df -h
Filesystem Size Used Avail Use% Mounted on
udev 12G 4.0K 12G 1% /dev
tmpfs 2.4G 1.2M 2.4G 1% /run
/dev/mapper/ubuntu--vg-root 28G 4.9G 21G 19% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 12G 144K 12G 1% /run/shm
none 100M 40K 100M 1% /run/user
/dev/sda1 236M 41M 184M 18% /boot
10.221.223.88:/segot_knfsv01_dsfs_1000/knfs01_dsfs_1000_q1000n 95G 21G 75G 22% /var/lib/graphite/whisper
10.221.223.88:/segot_knfsv01_dsfs_1000/knfs01_dsfs_1000_q1000n/.snapshot/hourly.2016-02-04_1405 5.0G 4.5G 535M 90% /var/lib/graphite/whisper/.snapshot/hourly.2016-02-04_1405
10.221.223.88:/segot_knfsv01_dsfs_1000/knfs01_dsfs_1000_q1000n/.snapshot/hourly.2016-02-04_2005 5.0G 4.5G 535M 90% /var/lib/graphite/whisper/.snapshot/hourly.2016-02-04_2005
10.221.223.88:/segot_knfsv01_dsfs_1000/knfs01_dsfs_1000_q1000n/.snapshot/hourly.2016-02-05_0205 5.0G 4.5G 535M 90% /var/lib/graphite/whisper/.snapshot/hourly.2016-02-05_0205
10.221.223.88:/segot_knfsv01_dsfs_1000/knfs01_dsfs_1000_q1000n/.snapshot/hourly.2016-02-05_0805 5.0G 4.5G 535M 90% /var/lib/graphite/whisper/.snapshot/hourly.2016-02-05_0805
ubuntu@vx910:~$

 

In this case we dont want them to see this, as it is mounted directly. Instead they should be able to browse to the snapshot manually by getting into the .snapshot directory. (same behaviour as of 7-Mode)

when i tried to remount the shares and then i see only one nfs path mounted, but later i see this snapshots directory mounted again.

 

,Sheel

4 REPLIES 4

Re: cDOT NFS - .snaphot directly automounting

Do you have autofs conigured on the unix host?

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: cDOT NFS - .snaphot directly automounting

No we dont have any automount configured!

Highlighted

Re: cDOT NFS - .snaphot directly automounting

did you managed to find the solution for this ?

Re: cDOT NFS - .snaphot directly automounting

This is a normal behaviour for newer linux kernels, e.g. CentOS 7. When you access a snapshot directory it will show as a mount because a different Filesystem ID is presented for the Snapshot.

 

The mounts will be ended automatically when it is no longer accessed. Sometimes they go stale when processes keep them open for monitoring. E.g. SNMP Monitoring of free space.

 

There are three possible solutions for this:

- change the process that keeps accessing the mount, to stay above the unmount timeout

- lower the timeout for the automatic unmount "/proc/sys/fs/nfs/nfs_mountpoint_timeout"

- change ONTAP behaviour of presenting different FSIDs for snapshot:

vserver nfs modify -vserver $name -v3-fsid-change disabled
vserver nfs modify -vserver $name -v4-fsid-change disabled

Additional information:

NetApp KB1009145

RedHat Solution 20388

Forums