Subscribe

iSCSI LUN with same name in one igroup (7mode 8.2.5) Win 2016 Server

Hi Team,

 

I have two iscsi Luns (7mode) in one igroup and both Luns are mapped to the one windows 2016 server.

 

Wed Mar 14 14:51:37 AST [eccnas5:lun.map:info]: LUN /vol/EX91VZ103/ex91vz103/data was mapped to initiator group VZ103=0
Wed Mar 14 14:51:48 AST [eccnas5:lun.map:info]: LUN /vol/vol8/ex91vz103/data was mapped to initiator group VZ103=1

 

As you can see both Luns are in different volumes but names of the Luns are same. One was old Lun which was mapped months ago and one is new.

 

But now, both Luns appearing as "Unallocated" on Windows server Disk Management.

Old lun was okay until customer added a new Lun to the same server.

 

Any idea what could be wrong here ?

Re: iSCSI LUN with same name in one igroup (7mode 8.2.5) Win 2016 Server

Hi @arsalankhan,

when Windows shows a disk as "Unallocate", it means it's not able to read the partition table inside of it anymore, same thing applies to LUNs.

You should make sure that the LUN you are presenting is in fact a Windows one with a Windows supported filesystem (from the output posted I cannot tell), and then use Microsoft's tools and support to help retrieve the partition table.

However, even if you manage to retrieve the partition table, it's impossible to determine the status of the data inside the filesystem, which could still be not consistent.

If you formatted the LUN as GPT, then it will contain more copies of the partition table and it should be possible to retrieve it. If the LUN was formatted MBR, then you have a single copy of the partition table which is now lost.

The alternative is to restore the LUN from a consistent backup (from both application and OS point of view), so a backup done through SnapManager or VSC normally.

 

Lorenzo