Data ONTAP Discussions

mbralign copy offload options Problem


I Have tried to do a mralign with copy offload options on a vmdk that a have on a vfiler.

mbralign whitout the copy offload is working..

I have tried difrent versions.

mbralign --access --path /vol/vol_os1/vmcomputer --debug /vmfs/volumes/nfs_sata_os1/vmcomputer/vmcomputer.vmdk

DEBUG=> desc=/vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer.vmdk, blob=/vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer-flat.vmdk force=0 sparse=0 bs=-1 mess=12800

MBRAlign will align with a blocksize of 8 kB.

        DEBUG=> looks like we have an mbr sig...

        DEBUG=> Connected to na-n1a which is a V3140 running:

        DEBUG=> P1 set a=0

        DEBUG=> 1 P1 OLDLBA=63, LENGHTSEC=31439142, NEWLBA=64, NEXTFREESEC=31439207, TYPE=07

        DEBUG=> Found lastend to be 64 >= NEWLBA 64and lasttype was 00

        DEBUG=> The last partition was an EBR, so this is OK.

Part    Type          Old LBA    New Start LBA      New End LBA     Length in KB     Old Next LBA     New Next LBA    New LBA of FS  Old length next  New length next

   P1      07               63               64         31439206         15719571

Creating a backup of /vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer.vmdk

Creating a backup of /vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer-flat.vmdk

        DEBUG=> Seeking to 16106127359 to mark EOF.

        DEBUG=> Able to seek to end of file.

        DEBUG=> opos = 0 but true

Creating a copy of the Master Boot Record

        DEBUG=> P4 had a zero lba.

        DEBUG=> P3 had a zero lba.

        DEBUG=> P2 had a zero lba.

Working on partition P1 (3): Starting to migrate blocks from 32256 to 32768.

Working on P1 (1): Starting to migrate blocks from 32256 to 32768.

        DEBUG=> co: start bytes : 32256

        DEBUG=> co: length :16096849920

        DEBUG=> co: new start : 32768

        DEBUG=> Original NFS: vmcomputer/vmcomputer.vmdk-mbralign-backup

        DEBUG=> Blobfilename NFS: vmcomputer.vmdk

        DEBUG=> co: Working on 1, which starts at 32256 and is 16096849920 bytes long.

        DEBUG=> $VAR1 = bless( {

                 'content' => '',

                 'name' => 'results',

                 'children' => [

                                 bless( {

                                          'content' => 'd2dd29d4-e5e8-11e0-bfad-00a0981029f6',

                                          'name' => 'copy-id',

                                          'children' => [],

                                          'attrvals' => [],

                                          'attrkeys' => []

                                        }, 'NaElement' )


                 'attrvals' => [



                 'attrkeys' => [



               }, 'NaElement' );

        DEBUG=> co: About to waitOnCopy op id is ---->   d2dd29d4-e5e8-11e0-bfad-00a0981029f6

        DEBUG=> Entering waitOnCopy with copy-id =d2dd29d4-e5e8-11e0-bfad-00a0981029f6.

Copy offload is completed.  100 percent complete.  14.99 gB copied. 15015

Making adjustments to /vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer-flat.vmdk.

        DEBUG=> ==================P1==================

        DEBUG=> P1 lba offset=454, lba=63,len=31439142, newlba=64, nextsec=31439207, type=07

        DEBUG=> ==================P1==================

        DEBUG=> P1 start CHS was C=0, H=1, S=1

        DEBUG=> lba of 64 = c:0.00398381574852163

        DEBUG=> lba of 64 = h:1.01587301587302

        DEBUG=> lba of 64 = s:2

        DEBUG=> calcchs got 64 and is returning 0,1,2

        DEBUG=> P1 start CHS should be C=0, H=1, S=2

        DEBUG=> P1 end 451 CHS was C=1023, H=254, S=63

        DEBUG=> lba of 31439206 = c:1957.00006224712

        DEBUG=> calcchs got 31439206 and is returning 1023,254,63

        DEBUG=> P1 end CHS should be C=1023, H=254, S=63

        DEBUG=> P1 updated lba: 454 with 64

        DEBUG=> P1 NBS hidden sector was 0, source had 0

        DEBUG=> P1 Updated NBS hidden with 64

        DEBUG=> P1 NBS vsize was 0 with an overflow of 0 (P1 length is 31439142), source had 0

        DEBUG=> P1 NBS bkup hidden was 64, source had 0.

Error: The source image P1 had starting offset 0 while the destination image has offset 64 in file name /vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer-flat.vmdk.

It is highly recommended you restore your vmdk file from the backup.

Shall I restore /vmfs/volumes/29e73332-53db7a94/vmcomputer/vmcomputer.vmdk from the backup I made?

All the info I can find on it is from 'mbralign --help':

mbralign - Align MBR partition table based vmdk files to NetApp storage systems

Usage: mbralign [OPTION]... VMDK FILENAME


   -a|--access controller:login:passwd     Credentials for the controller, login, and password. Used for NFS Copyoffloading only.

   --path            The NFS path. Used for NFS Copyoffloading only.

   --sparse          The resulting file will be sparse.  This option is

                      designed for NetApp NFS based datastores.

   --force           The default behavior is to skip properly aligned disks.

                      The --force option can be used to

                      override this. (Useful for migrating and making sparse).

   --bs=n            Use n as the block size (specified in kB).  n must be one

                      of (8, 16, 32, 64, 128, 1024).  The default is 8.

   -s|--secure       Use SSL for secure mode

   --preview         Show what would be done, then exit.  No changes are made

                      to the file.

   --scan all        Show current alignment of all flat-vmdk files, then exit. No changes are made

          filename   Show alignment of one flat-vmdk file, then exit. No changes are made

   --quiet           Only print warnings and errors (no other status is

                      printed to screen).

   --debug           Print debug comments.

   --help            Print usage.

   --thereAreNoVmSnapshots  Suppress the warning message about snapshots and

                             answer YES to the question of whether to continue.


Re: mbralign copy offload options Problem

I also have been experiencing the same issue.  Using VSC 4.0 with ONTAP 8.1 GA and ESX 4.0. 

Re: mbralign copy offload options Problem

Turns out copy offload does not work with ONTAP versions greater than 8.0.2 but then starts working again on 8.1.1.  Bug ID is 628256.