problem with disk ownership?

I'm working on a Metrocluster (n-series) where I'm having a problem with mirroring the root volume aggregate on one of the nodes.

When mirroring the root volume, I need to take ownership of three of the disks on the other metrocluster node.

However, both nodes claim that one of the disks is a partner disk.

When doing a "disk assign name_of_the_disk -o name_of_the_other_node -f" the console reports "diskown.RescanMessageFailed:warning]: Could not send rescan message to other_node".

Could this be a disk ownership problem? Could it be that disk in question is hardware-owned, and it should be software owned?


<Leiv, Norway>

Re: problem with disk ownership?

What does the "disk show <disk id>" command show as the owner and pool for the disk you want to assign?

It probably is already owned by the local node and you need to remove the ownership first before you can assign it to pool 1 of the remote node. The following KB should work, but I have only tried it on standard fas3050 cluster and not a metro cluster:

Make sure that the disk you want to reassign is on the spare list and remember to turn off auto assign while changing ownership.

Re: problem with disk ownership?

Sorry about this late summary.

I found a problem with a disk not being visable on the second controller. The primary controller saw the disk, but claimed that the disk was owned by "partner".

I finally rebooted the disk shelf containing the disk in question. This solved my problem.

The root cause was that there was a cabling error between the two controllers.

<Leiv, Norway>