Data ONTAP Discussions

Highlighted

"File transfer failed!" when using SCP to transfer files to CN1610

Hi All,

I was stumped when getting "File transfer failed!" using SCP to transfer files to a CN1610 switch.

 

First, I fixed the problem with the firewall.

Second, I added the required second slash at the beginning of the source path.

 

I could SCP the same file from a linux host with no issue, but on the switch still no success!

Here is the command and output:

 

(clus-sw2) #copy scp://userxx@longdomainname.company.com@12.123.123.123//var/tmp/test.scr nvram:script test.scr
Remote Password:**************

Mode........................................... SCP
Set Server IP.................................. 12.123.123.123
Path........................................... //var/tmp/
Filename....................................... test.scr
Data Type...................................... Config Script
Destination Filename........................... test.scr

Management access will be blocked for the duration of the transfer
Are you sure you want to start? (y/n) y
SCP Configuration Script transfer starting...


File transfer failed!

 

 

1 REPLY 1
Highlighted

Re: "File transfer failed!" when using SCP to transfer files to CN1610

Eventually figured out that with the domain name included it was too long. Removed the unnecessary part of the domain name and then it worked:

 

(clus-sw2) #copy scp://userxx@longdomainname@12.123.123.123//var/tmp/test.scr nvram:script test.scr
Remote Password:**************

Mode........................................... SCP
Set Server IP.................................. 12.123.123.123
Path........................................... //var/tmp/
Filename....................................... test.scr
Data Type...................................... Config Script
Destination Filename........................... test.scr

Management access will be blocked for the duration of the transfer
Are you sure you want to start? (y/n) y
SCP Configuration Script transfer starting...

 

Validating configuration script...

View solution in original post

Try the NEW Knowledgebase!
NetApp KB Site
Forums