snapmirror and sanpdrive

I have setup snapmirror relation between source and destination for a volume. Added the entry into the snapmirror.conf file and scheduled the snapmirror. I took the snapshot at the source using snapdrive to make the consistent snap shot . I invoked snapmirror quiesce and break via oncomand system manger so the destination volume will be read/writeable. Mounted the dr Lun at the destination server and tested all ok.  Everything worked up to this stage.

I took a snapshot at the destination server using snapdrive.

My intention was to reverse synch from dr to source filer after few test . I noticed that the snapmirror relation on the oncomand system manger was in unknown sate instead “reverse” or “resync “ with broken-off.  I was not able to reversesync  from the destination to source back since the only option was left to initialize from source to destination.

I can not think of any reason  why I did not have the option to reverse sync .  Is it something to do with oncomand sytem manager or snapdrive snapshot? I will appreciate experts who can help me on this.

Re: snapmirror and sanpdrive

I would not trust system manager at this point. It is quite possible that it needed SnapMirror.conf on source (i.e. new destination) or that it did not find common snapshot with "correct" name.

Next time start with doing reverse resync using CLI. This will also make troubleshooting easier.

Re: snapmirror and sanpdrive

Thank you for your quick reply.

Am i doing this at the source as below

source> snapmirror resync -S DST:vol1 SOurce:vol1

or DST>snapmirror resync -S  dst:vol1 source:vol1

Re: snapmirror and sanpdrive

To revert you do it on original source.

Re: snapmirror and sanpdrive

If there is no common snapshot then it is not going to resync . So we have to initialize from destination to source , am I correct?

Re: snapmirror and sanpdrive

Yes, that's correct.

Re: snapmirror and sanpdrive

I was able to recreate the issue today. I ran the initialization first then ran snap mirror via snap drive.

i made it sure that both place have common snapshot.

> snap list vol at both filer and noticed that both place has had common snapshot.

for an example ****.snap.25

I noticed that last snapshot (***.snap.25) at the dr site is being deleted/renamed when i mount the lun to snapdrive .

the sanpdrive gave this warning when i mounted the lun.

you are attempting to connect to a lun residing on a broken snap mirror swatination storage system volume. A snaprestore operation from the most recent consistent snapshot copy of the lun will be performed before the connection is established.

Re: snapmirror and sanpdrive

Any snapshot can be used as common base snapshot when doing resync, including SnapDrive consistent snapshot. Please show snap list from both source and destination.

Re: snapmirror and sanpdrive

SRN> snap list v_unitrends

Volume v_unitrends


  %/used       %/total  date          name

----------  ----------  ------------  --------

  0% ( 0%)    0% ( 0%)  Jul 18 10:51  DST(0142236780)_v_unitrends.3 (snapmirror)

  0% ( 0%)    0% ( 0%)  Jul 18 10:51  srv01_snap.0

  0% ( 0%)    0% ( 0%)  Jul 18 10:44  srv01_snap.1


srv01_snap_recent these snapshot are being created by snapdrive script.

the destination filer shows this after the snapdrive connected to lun.

DST> snap list v_unitrends

Volume v_unitrends


  %/used       %/total  date          name

----------  ----------  ------------  --------

  0% ( 0%)    0% ( 0%)  Jul 18 10:51  srv01_snap_recent

  0% ( 0%)    0% ( 0%)  Jul 18 10:45  DST(0142236780)_v_unitrends.2

  0% ( 0%)    0% ( 0%)  Jul 18 10:44  srv01_snap.0

  0% ( 0%)    0% ( 0%)  Jul 18 10:16  srv01_snap.1


the snapdrive is removing this snapshot

0% ( 0%)0% ( 0%)  Jul 18 10:51  DST(0142236780)_v_unitrends.3 (snapmirror)

Re: snapmirror and sanpdrive

I wonder, where srv01_snap_recent on source is gone? That seems to be the actual problem.

But with snapshots shown, you still have at least one common snapshot that should allow resyncing back (or forth).