Accepted Solution


Filer2> snapmirror initialize -S Filer1:vol34 Filer2:vol25

Fri Sep 28 07:28:13 GMT [Filer2: replication.dst.err:error]: SnapMirror: destination transfer from Filer1:vol34 to vol25 : could not find source filer.

Transfer aborted: could not find source filer.


Can Someone help me over the above, i have entries in both the filers but a ping is not working ...

Filer1> rdfile /etc/snapmirror.allow


Filer1> ping Filer2

ping: unknown host: Filer2

Filer2> rdfile /etc/snapmirror.allow


Filer2> ping Filer1

ping: unknown host: Filer1

Re: snapmirror


Well, how about DNS? Is it set up correctly so the names can be resolved correctly?

Did you try pinging by IP address, rather than filer names?


Re: snapmirror


Ping is working through the ipaddress and dns is also exist in the environment..

Re: snapmirror

Have you got relevant records for both filers on your DNS servers? E.g. can you resolve Filer1 & Filer2 (or ping) from any host sitting on the same subnet?

Also how about DNS on the filer itself? What's the output of:

Filer1> dns info


Re: snapmirror

Filer1 and Filer2 are not resolved by a host sitting in the same subnet.

Filer1> dns info

DNS is disabled

how to enable this for filers ??

Re: snapmirror

I'd start with adding static entries for both filers on your DNS server.

Then on the filers you can use System Manager GUI to set up DNS. Or set DNS options via CLI - to display them first type:

Filer1> options dns

Re: snapmirror

Filer2> options dns.enable on

** Option dns.enable is being set to "on", but this conflicts

** with a line in /etc/rc that sets it to "off".

** Options are automatically persistent, but the line in /etc/rc

** will override this persistence, so if you want to make this change

** persistent, you will need to change (or remove) the line in /etc/rc.

Fri Sep 28 08:54:35 GMT [Filer2: reg.options.overrideRc:warning]: Setting option dns.enable to 'on' conflicts with /etc/rc that sets it to 'off'.

Fri Sep 28 08:54:35 GMT [Filer2: rpc.dns.file.not.found:error]: Cannot enable DNS: /etc/resolv.conf does not exist

i checked  also ----

Filer2> rdfile /etc/rc

#Auto-generated by setup Wed Jan 18 04:45:42 GMT 2012

hostname Filer2

ifgrp create lacp vif0 -b ip

ifconfig e0M `hostname`-e0M flowcontrol full

ifconfig e0a `hostname`-e0a mediatype auto flowcontrol full mtusize 9000

ifconfig e0b `hostname`-e0b mediatype auto flowcontrol full mtusize 9000

route add default <default gateway> 1

routed on

options dns.enable off

options nis.enable off


ifconfig e0M partner e0M

vlan create vif0 3191

Re: snapmirror

also what is a procedure to quit after writing a file like if i write file wrfile /etc/snapmirror.allow , then after writing content to that file how to quit, i am using Ctrl+c, i dont think so its a correct option to quit ..

Re: snapmirror

I'm going to assume you are using wrfile...  ctrl-c is the correct option to quit, just make sure you do the ctrl-c on a new line.