Accepted Solution

un-owning disks presented to v6210 from ibm so we can re-present

Hi guys

we are performing some maintainance on our IBM SAN that is presented via LUNS to a v6210. (small snippet below of disks)

We are goign to change our raid on the ibm disk and have all the data moved off of it by virtue of snapmirror.

Now we are ready to destroy the ibm aggrs. After that, I thought we had to un-own or unassign the disks so we can then re-present it when we are ready to create the new aggrs after the RAID has been reconfigured. (or is simply destroying the aggrs good enough?

I didnt think there was a way to unassign but just to assing to one controlle ror the other. Obviously I do not want to unassign the netapp dosk but just the ibm stuff thats indicated below with the USCHIMDS1 nomencalture.

I ran a storage show disk command to see the info below. (obviously thetre are pages of this but wanted to provide some infor as an example.

1d.01.20                1   20  WD-WCAW32584372  NETAPP   X302_WVULC NA00

1d.01.21                1   21  WD-WCAW32558345  NETAPP   X302_WVULC NA00

1d.01.22                1   22  WD-WCAW32592631  NETAPP   X302_WVULC NA00

1d.01.23                1   23  WD-WCAW32552554  NETAPP   X302_WVULC NA00

USCHIMDS1:4-6.126L1     -    -  600A0B80006E36BC0000E9464DDCBB18 IBM      1818FAStT  0730

USCHIMDS1:4-6.126L2     -    -  600A0B80006E395A0000E9C94DDCBAEA IBM      1818FAStT  0730

USCHIMDS1:4-6.126L3     -    -  600A0B80006E36BC0000E9494DDCBB45 IBM      1818FAStT  0730

Any hints tips or tricks would be appreciated.

Thank you kindly in advance.

un-owning disks presented to v6210 from ibm so we can re-present

Ok folks - I am replying to my own post. As of writing this there are 27 views which means it had a slight pulse of intrest. Anyhow I reolved this. I will share what i did and perhaps it may help some one in the future. If not.. i only wasted a couple minutes writing this.

On my v6210 running ontap 8.01 I had to go to priv set advanced

then the command i was looking for was there I had to run a disk remove_ownership <disk name>

This way it would remove those names from the filers registry.

so somethign like this:

disk remove_ownership USCHIMDS1:4-6.126L1

disk remove_ownership USCHIMDS1:4-6.126L2

so forth and so on and I was good to go. We re did the raid on the IBM SAN it was then presented after i rebooted the v6210 one controller at a time by first doing a cf disable and then terminate cifs command.

Maybe there was another way but this is what I did and it worked for me as all the luns/disks came back as not owned whihc was my goal. I split them up to balance between controllers and assigned the disks accordingly. and good to go.