Developer Network Articles and Resources

Data ONTAP Simulator Introduction and Download Information

Data ONTAP Simulator for Linux Download Information: Data ONTAP Simulator (Password required. This tool is for Customers and Advantage Partners only)


What it is: A tool that gives you the experience of administering and using a NetApp storage system with all the features of Data ONTAP at your disposal.



How it works: The simulator can be loaded onto a Red Hat or SuSE Linux box and looks and feels exactly like Data ONTAP. It has the same code base (with additional wrappers to simulate the hardware) and is included in Engineering's nightly build process. The simulator is available for Data ONTAP 6.4.5 through 7.2.4.



Why it's cool: Almost anything you can do with Data ONTAP can be done with the simulator. Without purchasing new hardware or impacting your production environment, you can test functionality, export NFS and CIFS shares, set up fake tape drives, and even simulate two heads on the same box for clustering.



NetApp customers using this for...


  • Data ONTAP feature testing. The simulator includes fully functional license keys for all NetApp software. You can create WORM-protected files using SnapLock® and a simulated set of populated disks, and after the test you just delete the files instead of throwing away drives. You can test NetApp SAN functionality using iSCSI before implementing in a production FC or iSCSI SAN environment. You can also experiment with features such as FlexVolTM and FlexCloneTM before deploying Data ONTAP 7.0 on production systems.

  • Application integration. Application developers use the simulator to experiment with and develop applications that use Manage ONTAPTM APIs. The Manage ONTAP SDK (software development kit) contains documentation and C/C++, JavaTM, and Perl libraries.

  • Bug fix testing. The simulator can be used to confirm that a new release fixes a previous issue without having to physically touch a production machine. Assuming the bug fix is proven, you can test it on real hardware and know that time isn't being wasted with upgrades and downgrades.

  • Education. Every admin on your team can have a personal testing environment.



Caveats: This is not a production version of Data ONTAP and should not be used in your production environment. There are inefficiencies (for example, a 1GB disk file will be much larger than 1GB) and performance running on another OS without a disk system behind it will obviously be considerably less than with Data ONTAP. Finally, the simulator can't emulate environments where specific hardware is required (for example, Fibre Channel).

Please Note:

All content posted on the NetApp Community is publicly searchable and viewable. Participation in the NetApp Community is voluntary.

In accordance with our Code of Conduct and Community Terms of Use, DO NOT post or attach the following:

  • Software files (compressed or uncompressed)
  • Files that require an End User License Agreement (EULA)
  • Confidential information
  • Personal data you do not want publicly available
  • Another’s personally identifiable information (PII)
  • Copyrighted materials without the permission of the copyright owner

Continued non-compliance may result in NetApp Community account restrictions or termination.


Whenever I try to access the simulator link I get a DNS error.




let me know the exaxt error you are getting... I'll try to help you out... I would also need you IP settings at Simulator ost settings and it's DNS configuration.



Any ideas when a simulator based on 7.3 is coming out?


The sim is really scary for folks who are not familiar with linux -- could we maybe get a distro with the sim pre-installed in an linux VM? This is something students ask me for all the time.


Nick: There are step-by-step directions on how to setup Ubuntu with the Simulator on the Simulator website. I had Windows only people here follow it without any help to get the Simulator up and running.


Having just used those instructions last night (7.3 on ubuntu), I'd have to say they need to be updated. In the end, I was able to figure it out, but I can certainly see the difficulty if you don't have a Linux background.


Just picking up on the point about the simulator being a little tricky for non Linux people (like me).

I'm wondering if there is an active discussion thread adressing the installation and configuration of the simulator under "currently" available software such as the free VMware server version 2 and Ubuntu Linux 8.xx

There's no implied criticism of NetAp here, the sim works magnificently if you use the exact software stated in the guide but the guide itself is ageing a bit nowaways.


Dear Peter a.o.,

Please see my post in the (requires login) which address using Ubuntu 8.10 rather than 6x for simulators.

Kind regards,




My company bought IBM badged NetApp. Can I still access the Simulator? Can I register my IBM badged NetApp inventory on NetApp site to prove I am a NetApp customer?

Best Regards,



We're in the same boat. It would be very nice if IBM customers purchasing Netapp solutions could at least get basic NOW login access.



It's been such a long time since I posted the questio nthat I forgot all about it. Many thanks for posting that link to the Ubuntu updates.

All the best,


can someone comment on the limitations of fiber channel attach using simulator


Is there a way to obtain older versions of the simulators, older than 7.0?



am readind about netapp and i have downloaded a simulator.does it also have a file viewer http.could somebody explain to me how to use it..Do i  also physically add harddisks on my linux box.


I have registered but never got any confirmation.

I couldn't able to log into

Always got cookies error, even my cookies enabled.

Anyone can give me direct http download for Netapp simulator 7.3.iso ?




I've set up my REDHAT VM on workstation, ready to go but then I keep getting an unauthorised user page whenever I click the link for the simulator? Any reason for this - does anyone know what credentials I need to prove or show that I'm a valid customer.


Can you post a screen shot of the "unauthorised user page" please?

Also please detail exactly at which point you encounter this (i.e. when you access http...).


Hi, I have installed Data ontap 7.3 on ubuntu , Its working fine. I could able to log on the filerview. But i dont know what to do next. Can any help me what should i do after installation . I mean is there any step by step procedure .




By default, you have three very small drives in a single aggregate on which the root volume resides.  You might want to add say 25 1GB disks and create a new aggreate.  At that point, you might also want to download system manager and use that to manage you simulator.



I have to say that the simulator works well on Win XP when the instructions are followed - even with higher versions of Ubuntu (skipping some sections of the document).

The real pain I am having at the moment is coming from using Windows 7 Pro - when using VMWare server; starting Ubuntu freezes my laptop.

It would be great if I could get the simulator working using Windows 7, Ubuntu and Microsoft Virtual PC 2007.

I've tried setting up using this combination but am having difficulty with the network card settings, and have enabled NAT.

I can access the simulator CLI using the Virtual PC but not on the laptop the program resides on

I am unable to access the Fileview at all.

My next port of call would be Microsoft XP Mode, but am trying to keep the resources down to a minimum (this is a work laptop and cannot change OS).

I'm wondering if anyone else has set up using this combination of software before?


The simulator clones the MAC address of the NIC inside the virtual machine.  I run the simulator on Ubuntu on Hyper-V.  I use a legacy Network adapter, then on the settings, check the box to enable spoofing of the MAC address.


I am newbie in NetApp OS that I use ubuntu 8.04 Hardy Heron can be used if ?

if can how to please the steps to be used


Fibre Channel can not be simulated, if that's what you were asking.


I am trying to present an iSCSI LUN of 10Gb to two ESX4i servers. I can see the new LUN on my HBA adapter and have succesfully created a VMFS datastore. Whenever I try to deploy a template of a Windows XP VM or whatever to the VMFS datastore I see no progress at all. It seems the storage system is extremely slow. I have added 25 disks of 1024Mb and added 24 of them to aggr0. I then created a new volume of 10Gb and created an iSCSI LUN.

I have tried running the ONTAP sim inside an Ubuntu VM running on one of the ESX servers and I have tried running it on a physical machine with a Core i7 and 6Gb RAM with the same result: no VM can be created...

Am I missing something crucial here??

BTW, I am using 7.3.2...



I am currently downloading the simulation, but after the download is finished I need to follow  “Simulator ONTAP 8.0 Installation and Setup Guide for Microsoft® Windows® and Mac® Systems”  to get the machine up and running. After this, I need the Lab Manual or Simulation Manual, in order to log in, configure, etc.


Can I install 2 instances of the Simulator and do remote replication excercises.



Yes you can install 2 nodes of the simulator and do snapmirror or snapvault between the two nodes.


How to setup the environment by web access netapp? eg. http://IP/na_admin

how to configure to support web access during installation?




hi wwyhy

you can re-run the setup command to configure the web access.

hope this helps



I know the simulator is a learning/experimental tool and isn’t going to give you the performance of real NetApp hardware (as explained in the documentation), but I was wondering if there are any tools instead that can tell me/measure what the performance will be on real hardware for any test/applications I run in the simulator?




I'm running a MAC with Fusion and even after configuration the simulator is running in a boot loop when I try to start it up.  Any ideas?


Hi i work as SA with IBM but i can't download it cause im unauthorized. How can i get authorization?


i tried downloading the netapp simulator 7.3 and it keeps telling me i have unauthorised access.any way to get around this? my organisation own a netapp storage device FAS2020 with data ontapp 7.3.2 and i ve been having difficulty in putting it on our LAN so i can grant access for users to store item into it from remote locations.need help urgently



Did you login to the site?  Where did you get the unauthorized access?  If you have someone in your company that has access to download software from the site then they should be able to download the software for you.   The Data ONTAP 7.3.2 simulator is available on the site for all NetApp Customers and Partners.  If you have a support contract for your equipment and you don't have access to the site today then register on the site with your company email address and the serial number of the controllers of your system and you will then be authorized to download the simulator software.

Hope this helps..



          I want to download Data Ontap 8.1 ISO simulator. could you pls get me the link where i can dowload ISO image of the simulator.
quick response highly appreciated



Go to and select look for 8.1 in the table.


Hi All !

Someone knows if there is a simulator that works directly with Microsoft Hyper V  as a virtual machine ? Or even there are plans from Netapp to make it available ? I´m asking because as everybody knows, the Microsoft Windows 8 and Windows 8.1 comes natively with Hyper V feature to run your virtual machines on your latptop / desktop / tablet. You don´t need buy anything (just go to turn on / turn off Windows features in control panel ). And Microsoft Hyper V has more features and functionalities than VMware Player and VMware Workstation is a paid tool. Another reason: Microsoft Windows Server 2008 / 2008 R2 and Windows Server 2012 has Hyper V feature (just go to Server Manager / enable a feature). You can´t use VMware Workstation and Hyper V at the same time in a server. So, would be very nice to have simulator running on Microsoft Hyper V.

Another question. Someone knows if we already have a simulator 8.x able to run as HA pair ?

Thank you so much.



Hi i work as SE with lepide but i can't download it cause i am unauthorized.can i get authorization without any pay and how ?





Yes you can get access and it is free.  You will have to work with the folks in your company that have access to the site and get them to add you to their list of authorized users.   Once that is done then you can download, or of course once you find those that have access then you can just ask them to download it for you.

Hope this helps..



hi steve,

           thanks for suggest but my any folks are not have any account in netapp. netapp is new for me .firstly i create an account in community member after that i want to download netapp ontap 7.3 or higher version simulator  for testing purpose but i am not a partner or not a employee of netapp only i have a community member login. can i download simulator without making partner of netapp  if no how we make partner ? or can i download simulator without any pay ?

Thank you so much.




I am sorry but only NetApp customers and NetApp Partners that resell NetApp solutions have access to the Simulator.  If you want to see how our software works with our solutions you can access our FREE training on the communities site at:



yes you download this firstly you register for support and then wait 1day for access all resources then login on support at next day and follow

Download->software evaluation->data ontap simulator -> simulator 8.x-> 8.1-> download

Mark Thomson (Govind)


Hello Guys,

How to download netapp simulator .


I am getting error as


Unauthorized Access