Developer Network Articles and Resources

GUI for NetApp Support Tools


The GUI for NetApp Support Tools is a Windows GUI that helps execute some of the important NetApp support tools.


It includes a GUI for perfstat, nSANity, FTP Upload and the sending of autosupports.

You also can start FMC DC(Fabric Metro Cluster Data Collector) from tool.

No installation or setup needed.


The latest version is v1.05 (07.10.2014) and two different versions are available for download:

v105 - recommended version

v105x - Doesn't requires admin rights, but may not collect all the data in some situations


You can download the tool from the Support site:



- Update check/procedure on start

- GUI for perfstat 7

- GUI for perfstat8 Cluster-Mode

- GUI for perfstat8 7-Mode

- GUI for nSANity

- GUI to upload files over FTP to NetApp

- GUI to send Autosupports

- FMC DC can be started from tool

- Schedule functionality for perfstat

- Execute multiple perfstat (one after another)

- All necessary files are integrated in the tool.

- Possibility to download all tools for manual use

- Links to some useful websites


Features in v1.05 (released 07.10.2014)

- NEW: Perfstat8 C-Mode - possibility to use a SSH Key for an automated method.

- NEW: Perfstat8 C-Mode - execute multiple perfstat (one after another)

- NEW: Perfstat8 C-Mode - schedule functionality

- CHANGE: Some links have been updated

- CHANGE: Several minor changes

- FIXED: Perfstat8 - generates the correct command now for the Cluster Mgmt IP











Please Note:

All content posted on the NetApp Community is publicly searchable and viewable. Participation in the NetApp Community is voluntary.

In accordance with our Code of Conduct and Community Terms of Use, DO NOT post or attach the following:

  • Software files (compressed or uncompressed)
  • Files that require an End User License Agreement (EULA)
  • Confidential information
  • Personal data you do not want publicly available
  • Another’s personally identifiable information (PII)
  • Copyrighted materials without the permission of the copyright owner

Continued non-compliance may result in NetApp Community account restrictions or termination.


Thank you very nuch for that tool. It's been part of my toolbox since 1.02.

Great news to have it under the official NetApp umbrella !


I've had to use this tool many times and when all else fails this does the trick the majority of the time.

I've used it to run perfstat and nSANity and have had very few problems with it at all. This was back when it wasn't fully supported by NetApp but still it was a great tool.

Thanks for finally bringing it into the fold NetApp!


This is a very useful tool and I am using it from the very first version on.

But with the latest version 1.06 I have an issue with the SSH keys: it seems like the keys are not valid long enough.

I generate the key-pairs for a scheduled run in the early morning hours - when coming to work, the tool asks me for admin-pw and pub-key filename - giving those the tool still isn't able to connect due to invalid authentication.

Am I missing something or is there room for improvement?


Hello Guys,

nSANity Part in Version 1.06 is not working for cDOT 8.3, so I can not use this tool to collect data from our storage systems. Will this be fixed soon,

because otherwise this tool is not useable for current cDOT systems and Metrocluster?


Trying to connect to CDOT 8.2.2 cluster or nodes usinng Support Tool v10.6 .  All fail with error:


"Unable to connect to the Cluster Managment IP 

Please check the IP/Name and login information"




"Unable to connect to both Nodes

Please check the IP/Name and login information"


Edit to add that selecting Skip at the first logon allowed me to start and run the tool.


I am trying for automating the tasks that are done using 'On command tool' for NetApp c mode.Would anyone suggest me which scripting language shall I use , is it Perl or Powershell or please mention if there are other ideas also. 




I have a customer that is running the tool and has received the following errors:


Opening WMI namespace Microsoft/SqlServer/ComputerManagement
Windows collector: unexpected WMI exception opening connection - <class 'wmi.x_w
mi'>, <x_wmi: Unexpected COM Error (-2147352567, 'Une exception s\x92est produit
e.', (0, u'SWbemLocator', u'Espace de noms non valide ', None, 0, -2147217394),


Unexpected exception occurred, exiting
Traceback (most recent call last):
File "", line 2576, in <module>
File "", line 564, in runCollectors
File "", line 300, in _dispatch
File "", line 1577, in collectWindows
File "", line 274, in log
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 90: ordinal
not in range(128)


Not sure if this is related to something local to the user. Any thoughts?


Hi there


we cannot connect to Ontap 7 version, 8.2 .It gives us the error

( Unable to connect to both Nodes

Please check the IP/Name and login information ).


we did not setup open ssh or RSH ,just run the tool with 7mode ,


tried to run as admin  didnot help either.



Thanks a lot




  1. Create a folder C:\Perfstat
  2. Download GUI for NetApp Support Tools from here to C:\Perfstat
  3. Download plink.exe from here to C:\Perfstat
  4. Open command prompt and browse to C:\Perfstat
  5. Run plink.exe “controller ip”, if you have 2 controllers you need to run this to both IPs
  6. Answer yes or enter to any prompts, and once you have connected you can close the session (close command prompt)
  7. Using file explorer, browse to C:\Perfstat and launch the GUI for NetApp Support Tools.
  8. Click on Perfstat 7 and enter the controller IP, username and password
  9. Set the Perfstat to run for required duration from Perfstat time dropdown box

hi again ,


we followed your suggestions , what happened is as follows

1-we logged first time with plink ,then run the GuiPerfstat , but same error occured

2-then tried again ,and this time plink does not connect ,it gives the error "access denied"

3-we moved to a new pc , tried the same things, and same error again


so we could not get further .


any other thing to advice...




Hi ousturali,


do not use user "naroot" - you need to login with user "root" or any other user to the ONTAP cli.




hi ,


finally we got it .THe problem was very strange.

The version that we use for support tools gui somehow creates the plink file  to the  running directory     , but in fact the plink file , it does not really working.

then we downloaded new plink and run the perfstat both in another directory , everthing worked charmly.

 please take care while  running the app , i had used this software lots of time , but this was the first time that i had encountered something like this.







Is this tool still available for download?    The URL mentioned at the top no longer works and I don't see this tool listed in the Toolchest (even the Legacy).





Tools is not available??
can you please update the link?


Sorry - bad news - the NetApp Support Tool was used to more easily capture 7m PERFstats and nSanity data, but it has been removed from the Support site and is no longer maintained/available. Perfstat and nSanity is still available.


if this tool is no longer downloadable,  where can download nSANity GUI? the CLI version does not support cDOT 8.3 or above.


Hi Team,


can you share the link for download and it is support Windows 10 OS 64bit. 



Thank you,




"Sorry - bad news - the NetApp Support Tool was used to more easily capture 7m PERFstats and nSanity data, but it has been removed from the Support site and is no longer maintained/available. Perfstat and nSanity is still available."



Wow that's sad news indeed. This was the only "easy" perfstat for 7DOT.



Reincarnation of the utility is gPerfstat:

perfstat 8.3 (7-Mode & cDOT)

perfstat 8 for cDOT only


@D_BEREZENKO   Thanks!   That 8.4 Perfstat with GUI is great.


Still wish they had continued development on a GUI for nSANity -- easier to get Customers to run that tool when it was GUI.  



Hi Guys,

The GUI for NetApp Support Tools should be available again soon with some improvements for cDOT.
Some modification had to be done, to fullfil some new NetApp requirements.

If someone needs to download the tool, feel free to contact me directly.