E-Series, SANtricity and Related Plug-ins Discussions

Highlighted

Error reading device using LVM on CentOS with iSCSI E-Series volume

I have a CentOS 7 system (3.10.0-957.12.2.el7.x86_64) with Unified Host Utilities 7.1 installed and multipathd configured & enabled.

 

When I run pvcreate on the /dev/mapper/xxxx devices I get a series of errors below, although the command then completes successfully.  Is there any configuration I can use which will suppress these errors?

 

# pvcreate /dev/mapper/StorageGRID_*
  Error reading device /dev/sdr at 0 length 512.
  Error reading device /dev/sdr at 0 length 4.
  Error reading device /dev/sdr at 4096 length 4.
  Error reading device /dev/sds at 0 length 512.
  Error reading device /dev/sds at 0 length 4.
  Error reading device /dev/sds at 4096 length 4.
  Error reading device /dev/sdt at 0 length 512.
  Error reading device /dev/sdt at 0 length 4.
  Error reading device /dev/sdt at 4096 length 4.
  Error reading device /dev/sdu at 0 length 512.
  Error reading device /dev/sdu at 0 length 4.
  Error reading device /dev/sdu at 4096 length 4.
  Physical volume "/dev/mapper/StorageGRID_BASE_OSBOOT" successfully created.
  Physical volume "/dev/mapper/StorageGRID_CONTAINER" successfully created.
  Physical volume "/dev/mapper/StorageGRID_OBJ_VOL0000" successfully created.
  Physical volume "/dev/mapper/StorageGRID_OBJ_VOL0001" successfully created.
1 REPLY 1

Re: Error reading device using LVM on CentOS with iSCSI E-Series volume

Hello 

 

Is any other storage box attach to the host apart from the NetApp and are you sure these errors are reported from the NetApp storage itself.

 

And also confirm if you can navigate to the path were the errors are reported and see the content inside the folders.

 

Thanks

Vinay

Forums