E-Series, SANtricity and Related Plug-ins Discussions

Highlighted

SANtricity Unified Manager SSL Port

Hi all,

 

I have configured the SANtricity Unified Manager to use 443 as SSL Port but when I click a Storage Array from the Unified Manager, it calls the urls with 8443. When I edit the URL manually to use the port 443, it works.

 

This is the URL that I get when I click "Launch" from SANtricity Unified Manager: https://<storage-ip>:8443/sm?proxyIp=<proxy-ip>&xsrfToken=blabla >>> I get "cannot connect to website" error

 

then I edit it like follows: https://<storage-ip>:443/sm?proxyIp=<proxy-ip>&xsrfToken=blabla >>> then it works.

 

 

wsconfig.xml : 

 

<!-- non-ssl port if not specified, no listener is made-->
<sslport clientauth="request">443</sslport>
<!-- comma seperated list of protocols Possible values: SSLv3,TLSv1,TLSv1.1-->
<exlude-protocols>SSLv3</exlude-protocols>

<port>80</port>
<workingdir>/opt/netapp/santricity_web_services_proxy/working</workingdir>
<datadir>data</datadir>
<appkey>webapi-2.0</appkey>
<enable-auto-update>true</enable-auto-update>
<userauth>ldap</userauth>

 

I have restarted the services as well as the host. Where do I make the mistake?

 

Regards.

 

1 REPLY 1
Highlighted

Re: SANtricity Unified Manager SSL Port

Hello - I checked into this and found that it's not possible to modify the launch port for the SANtricity UM System Manager from 8443.

View solution in original post

Try the NEW Knowledgebase!
NetApp KB Site
Forums