E-Series, SANtricity and Related Plug-ins Discussions

help with SANTricity Splunk app

I recently installed the SANTricity Performance App for Splunk (along with the technology add on) and I'm having trouble seeing any data. I followed the directions on the splunk app pages, but when I load any dashboard in the app I don't see any data. I'm not even really sure how to debug this, and NetApp support doesn't support these apps. Any help would be appreciated.

 

Thanks.

2 REPLIES

Re: help with SANTricity Splunk app

I have installed the app a number of times and should be able to help you try to pinpoint the issue.

 

Did you use the provided scripts to add the array under management by Web Services Proxy? If so, have you attempted to connect to Web Services Proxy and verify that the arrays are being managed correctly?

Re: help with SANTricity Splunk app

Aditional items to try along with Eric's statement:

From the Splunk search page query with index="eseries", let us know if there is any data returned.

 

If the web services proxy is running on a Linux server, make sure it actually started: /opt/netapp/santricity_web_services_proxy/web_services_proxy status

If you ran the Splunk Add_Array scritp and it was succesfull you should see entries on the web services server in /opt/netapp/santricity_web_services_proxy/working/arraydata.xml for the array being monitored, don't edit the file, but cat it to see if the array was added.

The logs for the web services can help, default location is /opt/netapp/santricity_web_services_proxy/working/logs and the trace.log.0 will have the most information in it and tell you if it started correctly it will also show you if it is collecting data from the E-Series arrays.

You may need to drop SElinux (firewall) on the web services server as a test if it can't connect to an array.

For the performance data the wsconfig.xml file will need to be modified per the web services instructions to get the performance data to collect. 

 

Mike

 

Forums