FAS and Data ONTAP Articles and Resources

How to use NetApp Storage System Plug-in for Oracle Enterprise Manager

 

Introduction
The NetApp Storage System Plug-in for Oracle EM delivers comprehensive availability and performance information for NetApp storage systems. By combining NetApp storage system monitoring with comprehensive management of Oracle systems, Cloud Control significantly reduces the cost and complexity of managing applications that rely on NetApp storage and Oracle technologies.

 


 

Step1: Download the NetApp Storage System Plug-in

 

Step2: Install as per Installation and administration guide to have new features like:

 

  • SAN support (both ISCSI and FCP)
  • Support for Oracle ASM (Both NFS and SAN)
  • BI publisher reports for new features
  • Few new metrics
  • ONTAP 9.0 Support

 

Other Resources

 

 

Warning!

This NetApp Community is public and open website that is indexed by search engines such as Google. Participation in the NetApp Community is voluntary. All content posted on the NetApp Community is publicly viewable and available. This includes the rich text editor which is not encrypted for https.

In accordance to our Code of Conduct and Community Terms of Use DO NOT post or attach the following:

  • Software files (compressed or uncompressed)
  • Files that require an End User License Agreement (EULA)
  • Confidential information
  • Personal data you do not want publicly available
  • Another’s personally identifiable information
  • Copyrighted materials without the permission of the copyright owner

Files and content that do not abide by the Community Terms of Use or Code of Conduct will be removed. Continued non-compliance may result in NetApp Community account restrictions or termination.

Replies

If you are using 8.3.1 P1 with sslv3 disabled and only tls1 enabled in Ontap,  the jdk version within the Oracle Agent needs to be updated from what I think was the default.

 

We were running with 1.6.0.43 within agent12c/core/xxxxxx/jdk, we updated to 1.6.0.95 and connectivity was ok once more.

 

I followed:

 

Oracle Support note Steps for Implementing TLSv1 with OEM 12.1.0.4 to Fix Poodle Attack (Doc ID 2059368.1)

This one also relates:

CVE-2014-3566 Instructions to Mitigate the SSL v3.0 Vulnerability (aka "Poodle Attack") in Oracle Enterprise Manager Grid / Cloud Control (Doc ID 1938799.1)

 

(Bit stange as pre 8.3.1 P1 running 8.2 tls1 was fine with the older version of the jdk)

 

 

I would like to thank Sachin @ Nettapp or their help. This was provided as a command line way to check if the plugin could talk to the agent:

 

To validate that NetApp Plug-in jars are able to communicate using TLSv1 protocol with ONTAP system, please run the following steps:

  1. Login to OEM Agent host wirh oracle user credentials where NetApp plug-in has been deployed.
  2. Goto /<OEM_AGENT_HOST>/agent_inst/agent_inst/sysman/config/emd.propetries
  3. cat  /<OEM_AGENT_HOST>/agent_inst/agent_inst/sysman/config/emd.properties| grep JAVA_HOME
  4. cd inside java_home
  5. java -jar <OEM_AGENT_HOST>/agent_inst/plugins/netapp.storage.sys.agent.plugin_12.1.0.3.1/scripts/OEMDataCollector.jar <VSERVER_MGMT_IP> 443 <vserver_user_account> <password> vsresponse

example: java -jar /u11/app/agent_inst/plugins/netapp.storage.sys.agent.plugin_12.1.0.3.0/scripts/OEMDataCollector.jar 10.232.14.56 443 vsadmin netapp1! vsresponse

em_result =1

  1. If output is 1, NetApp Plug-in is able to communicate with Storage server and there are issues with OEM setting for TLSv1. If  output is 0, problem with NetApp Plug-in which we need to investigate further.
  2. If output is 1, try following command which communicated with storage server to retrieve details:

java -jar <OEM_AGENT_HOST>/agent_inst/plugins/netapp.storage.sys.agent.plugin_12.1.0.3.1/scripts/OEMDataCollector.jar <VSERVER_MGMT_IP> 443 <vserver_user_account> <password> vsproductinfo

 

When the agent was failing we got this in the log:

 

agent12c/plugins/netapp.storage.sys.agent.plugin_12.1.0.3.1/scripts/log/NetAppPlugin.log

 

[2015-11-17 13:07:15,752] [main] [ERROR] Failed to initialize Zapi runner. :com.netapp.autozapi.client.ApiProtocolException: Connection error to Storage System 10.1.x.x: Remote host closed connection during handshake

 

hope this helps someone else.

 

Chris

 

Thank you, Chris for sharing your learnings on public forum for benefit of others.

Finally, Netapp Storage Plug-in for ONTAP version 8.3.1 with TLSv1 protocol enabled worked after upgrading Java version and applying patch as provided by Oracle.

 

 

 

Sachin,

 

We were trying to monitor a new ONTAP 9 controller via EM. We have EM 12cR3, with plugin 12.1.0.2. When I tried to add the new clustered ONTAP system, it gave an error saying "is not reachable over the network or is down".

 

I undeployed the 12.1.0.2 plugin and trying to install the latest version. The first step to add the new opar file to the EM software library is failing

 

oracle@rdlvp63{oms}[/u01/app/oracle/product/oms/mw_home/oms/plugin]$ emcli deploy_plugin_on_server -plugin=12.1.0.4.0_netapp.storage.sys_2000_0.opar
Enter repository DB sys password:

Performing pre-requisites check... This will take a while.
Invalid plug-in ID or version.
Error message is: Ill formed plugin id 12.1.0.4.0_netapp.storage.sys_2000_0.opar
For details, check the Management Server logs.

 

I'm not sure if this is an EM issue or a plugin issue. Can you help.

 

Thanks.

I was able to download and install the 12.1.0.4 version of the plugin.

 

After I add the new target, I see this when I navigate to the target home page

 

Error during operation: SqlQuery.runQuery
Error #1009

 

Thanks.

Hello, 

 

can you please send me the screenshot to nkarthik@netapp.com?

 

Regards 

Karthikeyan.N

Karthik,

 

There are multiple errors I see when I navigate to the target home page. It's best if I can show you via a webex.

 

Let me know and I can set it up.

 

Thanks

Naveen

Has anybody bee able to install this with EM 13c?  I am running 13.2 of EM

 

Thanks

Will there be an updated version of this plug-in to support Oracle Enterprise Manager 13c?

Was there ever a response back as to whether there will be a 13c plug-in for OEM?

Also, has anyone encountered an issue where an SVM reports as being DOWN when the Cluster and all other SVMs report UP?

 

n doing some digging into the OEM logs we see these errors:

[2018-08-16 14:28:48,079] [main] [ERROR] Failed to initialize Zapi runner. :com.netapp.autozapi.client.ApiProtocolException: Connection error to Storage System 192.168.10.100: Connection refused
[2018-08-16 14:30:15,314] [main] [ERROR] Failed to get network interface error rate : Metric [CsNetworkInterfaceError]::com.netapp.autozapi.ApiExecutionException: Object "ifnet" was not found.
[2018-08-16 14:30:20,616] [main] [ERROR] Failed to initialize Zapi runner. :com.netapp.autozapi.client.ApiProtocolException: Connection error to Storage System 192.168.10.100: Connection refused

The error from OEM is:

The error message reported is that filer1 is unreachable over the network or is down.

 

[SOLUTION]

After doing a lot more digging I found out the issue.

 

For some reason when all of the other SVMs were created for CIFS, management was enabled on those LIFs.

The one converted from 7-Mode (7MTT) did not have mgmt enabled only data.

 

When I enabled mgmt on the LIF it established connection and OEM now reports it as UP.

Appreciation goes to @winkel helping me discover the solution

After installing this plug-in and configuring the NetApp-Filers we get every week an AutoSupport-Message with the following subject:

 

HA Group Notification from <NetApp_controller> (USER_TRIGGERED (ALL:NetApp Storage System Plug-in for OEM. Plug-in Version: 12.1.0.3.0. Controller ONTAP Mode = Cluster : Controller ONTAP version = NetApp Release <NetApp_Release>)) NOTICE

Is this behaviour expected? Can we somehow modify these settings?

So now that I am able to monitor a SVM successfully, I have run into a new problem - REPORTS

I navigate to the SVM and in the lower left there are links to Reports such as FlexCone Storage Savings, Volume Utilization, Storage IOPS/Latency, etc.

 

However, when I click on the links it opens a new browser window with the following error:

Error 404--Not Found

Error 404--Not Found

From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:

10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.

 

I reached out to Oracle on the issue and since it is a NetApp plug-in they offered only a re-direct to NetApp Community for help.

Forums