FAS and V-Series Storage Systems Discussions

Anyone knows how to map a luns from netapp to solaris host?

VGENTNER01

Hello to everybody this is the case!

I made two luns on a NetApp 3020 and want to map it to a solaris 8 host, anyone knows the procedure for viewing on the server with solaris 8. Both belong to the same igroup and where host initiator is .

Thank you!

7 REPLIES 7

baijulal

You can install  NetApp host Untility Kit (HUK, downloadable from NOW site) for solaris.

On Solaris 10, you can use cfgadm to scan/discover new LUNs, please refer to man pages.

Once the LUN is being detected by OS, sanlun commands (from HUK)from the host utilities can be used to query/display NetApp LUN information.


Eg #sanlun lun show -p



VGENTNER01

thanks for your answer but what I need is for solaris 8, I'm trying to look for huk for solaris 8 if I do ill give you the correct answer

sinhaa

The command cfgadm works on Solaris 8 as well, only the format is little different. Can you try the following:

cfgadm -al -o show_FCP_dev

Host Utilities Kit ( also called Host Utilities) for Solaris will work on Solaris 8 just as good as on Solaris 10. I didn't see any Solaris version in the setup requirements section. So I assume it should work with all versions.

download it from here:

http://now.netapp.com/NOW/download/software/sanhost_sol/Solaris/


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

sinhaa

A good website for this is http://www.idevelopment.info/data/Unix/Solaris/SOLARIS_ConnectingToAniSCSITargetWithOpen-iSCSIInitiatorUsingSolaris.shtml .

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

VGENTNER01

Thanks for that guide but im looking for FCP not ISCSI, if you have a guide like that one for FCP i will appreciate if you send it to me. thanks!

eric_barlier

Hi,

Can you please describe the problem you are having? Also make sure your igroup is of SOLARIS.

Eric

GHALIEDWILLIAMS

Well for Solaris 8, adding storage can be a hit and miss affair. I would try (please check parameters for the commands before running them):

1. cfgadm

2. Update sd.conf and run update_drv

3. luxadm

4. Reconfiguration reboot

I used to insist on downtime and doing reconfiguration reboot because that was the only sure thing.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public