FAS and V-Series Storage Systems Discussions

Lun Corruption?

Hello .I have Netapp Fas2020 i made a volume and Lun i have present it to my File Server 2012R2 through the initiator and mounted up .Format it with Refs files system .So far so good .Then user droped some large file on it and there was not more free space and windows could not mount it .I went ot the Fas2020 Volume setting and increase the size .Was working for a couple of weeks and then i did resize it once more for the same reason and was working fine ...

After a windows update the volume is mounted on windows but its on RAW.When i dismount and mount it again i get the error that Refs file system is not supported on drive :P wich is the isci but it stills mount it with RAW .

Any ideas can i recover the files from the LUN some how .

Thanx in advance .

 

4 REPLIES 4

Re: Lun Corruption?

If you don't have a snapshot, I doubt it.

 

I would recommend enabling autogrow. Keep in mind a LUN is just a blob to ONTAP. ONTAP can only see that it is a 1s and 0s file. It maps to a host and is formatted with a file system by the host.

Highlighted

Re: Lun Corruption?

Ok Noted.

One more question .I had snapshots desabled  before the disaster a week or so .How i utilize that feature is it possible from old snapshots to recover? Btw dident find any option for Autogrow in FileViewer is under the volume setting's or Lun settings ?

And does the Volume space should match with LUN ? In my understanding Volume should be always bigger than Lun since Lun is just blob?

Thank you.

Re: Lun Corruption?

It's a volume option. And you might be able to create a clone of that volume. I think 7.3 had that, but it's been years since I've dealt with that version.

Re: Lun Corruption?

Hey i manage to recover all the files with a program it took me a month to do it but it seams that all the files are intact and not corrupted .

Thank you for your support.

Forums