FAS and V-Series Storage Systems Discussions

NVRAM size mismatch between nodes detected

SEIMTEXTER

Hello,

 

I have a FAS2552 with each controller reporting this during boot.

 

Feb 15 15:10:57 [<arrayname>:nv.partner.size.mismatch:ALERT]: CF monitor: NVRAM size mismatch between nodes detected; node requires 661651456 bytes, partner exported 0 bytes.

 

Nodes are cabled correctly and it's just a 2-controller / no expansion switchless cluster running ONTAP 9.7.  Any ideas are welcome, but I need to get this fixed! 

 

Doesn't appear to be a bad NV DIMM -

 

2552::> system fru-check show
Node FRU Status
------------------ ---------------------------- -----------
2552-01
DIMM-1 pass
DIMM-NV1 pass
2552-02
DIMM-1 pass
DIMM-NV1 pass
BootMedia pass
PCIe Devices pass
6 entries were displayed.

What's going on here?

1 ACCEPTED SOLUTION

paul_stejskal

I think it's normal. If one node is offline or powering up, the size will of course be different. I've always seen it and put it in the "that's normal output" category of my brain.

 

View solution in original post

11 REPLIES 11

hmoubara

Hello,

 

Is the error mentioned only seen during boot?

Can you verify the health of the cluster:

 

>  system ha interconnect status show

> cluster show

 

Thanks

SEIMTEXTER

yep, it's only during boot, and the array seems to be healthy otherwise.  Not sure if I should be concerned about it or just ignore it? 

 

> system ha interconnect status show

not sure where to run this.  it looks like ha can either expand out to hardware or halt, but is not valid by itself, at least at my runlevel (at the cluster(?) prompt)  Cdot is still pretty foreign to me, I mostly still work on 7-mode.

> cluster show

both nodes show true for health and true for eligibility, whatever that means, I assume it's good!

paul_stejskal

What is the serial #? It may be good to open a case if you have entitlements.

SEIMTEXTER

yeah we don't have entitlements or a support contract unfortunately.  Seems like it's working fine, it just spits that error out on boot ¯\_(ツ)_/¯

andris

system ha interconnect status show is a privilege: advanced command.

::> set advanced

::*> system ha interconnect status show

navion

Also getting several nv.partner.size.mismatch on every ONTAP update.

paul_stejskal

I think it's normal. If one node is offline or powering up, the size will of course be different. I've always seen it and put it in the "that's normal output" category of my brain.

 

View solution in original post

SEIMTEXTER

I'm with you 100% on that.  we replaced the entire filer and the "error" persisted, but no visible alerts or performance issues related to that message.  Thanks everyone!

Mjizzini

This could have happened during reboot while the interconnect was down.  

To verify the health of the interconnect, run  the command below.

::*>storage failover show -instance

 

If the interconnect link is fine, a takeover giveback should clear this issue.

navion
According to KB:

Cause
The interconnect is temporarily link up and down.

Solution
No action is required as it is automatically restored.

SEIMTEXTER

Thank you for that KB article, that's it exactly.  If someone who works for NetApp can expand the list of affected systems, that would probably help others find it faster.  Thanks again all.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public