FAS and V-Series Storage Systems Discussions

ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Hello,

 

It's the first time I post on this community,

I have one problem with FC and would like just have some precisions with Vmware don't see lun.

 

The connexion to vmware don't working

igroup show
          Vserver Name: svm_fc
           Igroup Name: ESX01
              Protocol: fcp
               OS Type: vmware
Portset Binding Igroup: fc_pset_1
                  ALUA: true
            Initiators: 21:00:00:24 (not logged in)

 

And if I make a fcp ping initiator on ESX's WWPN I have

    Remote WWPN: 21:00:00:24:ff
       LIF Name: NODE-01_fc_lif_1
           Node: NODE-01
    Ping Status: zone-info-not-available

The topology show see the fabric 

vserver fcp topology show -vserver svm_fc
svm_fc
        NODE-01_fc_lif_1
                       1      SWITCH_BROCADE300_1 10:00:00:05:33:  24

 

Do you know what exactly "zone-info-not-available" are ?

Do you know where I can found more logs ?

Firmware Version of switch are check in IMT.

 

Thank you very much,

18 REPLIES 18

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Are there other luns that you can see?  

 

Do you have zoning in place between the initiators (host(s)) and the Targets (NetApp) ?    It doesn't look like that host is logging in to the storage.  

 

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Hello,

Thank you for your quick reply.

 

No AFF are the first connected to existent Fabric with EMC FC Storage.

- Zoning (it's not me which manage brocade) at make by specify WWPN of LIF Netapp (Start by 20: and not 50Smiley Happy and WWPN of Vmware.

- We check also NPIV on Brocade.

- We make a portset in SVM mapped to igroup

- We make an igroup in SVP mapped to LUN with WWPN of Vmware HBA

- We check also the LUN ID for not have an existing LUN ID in ESX

 

If I do a "network fcp topology show" I can see the switch with all ports and WWPN connected

And if I do "network fcp zone show" (I don't have a valid system for check what he must return) :

::> network fcp zone show
Warning: Unable to list entries for kernel on node "NODE-01": Fabric query operation timed out or was rejected.
         Unable to list entries for kernel on node "NODE-02": Fabric query operation timed out or was rejected.
Error: show failed: Fabric query operation timed out or was rejected

I have no more idea what I can do for check if this is a netapp problem.

 

 

Thank's,

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

if you run "fcp initiator show"  does it show anything?  if nothing, then the issue is most likely in the zoning.   

 

Do you see the WWPNs flogi-ing on the switchs?   

 

can you also post the output of the following? 

 

net port show 

net int show -vsever <fcp vserver name> 

portset show 

igroup show 

lun mapping show 

 

 

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

I try to give you all information (from my note) since i have no access to storage until tomorrow.

I hope you see someting !!

 

 

::> vserver fcp initiator show -vserver svm_fc
There are no entries matching your query.

 

 

 

::> ucadmin show
                       Current  Current    Pending  Pending    Admin
Node          Adapter  Mode     Type       Mode     Type       Status
------------  -------  -------  ---------  -------  ---------  -----------
NODE-01    0c       cna      target     -        -          online
NODE-01    0d       cna      target     -        -          online
NODE-02    0c       cna      target     -        -          online
NODE-02    0d       cna      target     -        -          online

 

 

 

::> network interface show -fields wwpn,curr-port,lif (LIF are fine data and fc protocol)
svm_fc        NODE-01_fc_lif_1                         0c        20:05:d0:39:ea:09
svm_fc        NODE-01_fc_lif_2                         0d        20:06:d0:39:ea:09
svm_fc        NODE-02_fc_lif_1                         0c        20:07:d0:39:ea:09
svm_fc        NODE-02_fc_lif_2                         0d        20:08:d0:39:ea:09

 

::vserver fcp interface> show
           Logical    Status                      Current       Current Is
Vserver    Interface  Admin/Oper  WWPN            Node          Port    Home
---------- ---------- ----------- --------------- ------------- ------- ------
svm_fc 
           NODE-01_fc_lif_1 
                         up/up    20:05:d0:39:ea:09
                                                  NODE-01   0c      true
svm_fc 
           NODE-02_fc_lif_1 
                         up/up    20:07:d0:39:ea:09
                                                  NODE-02   0c      true

 

 

 

 

::> portset show -instance
    Vserver Name: svm_fc
    Portset Name: fc_pset_1
 LIF Or TPG Name: NODE-01_fc_lif_1, NODE-02_fc_lif_1
        Protocol: fcp
 Number Of Ports: 2
Bound To Igroups: IGROUP_ESX

 

 

 

::> igroup show -instance
          Vserver Name: svm_fc
           Igroup Name: IGROUP_ESX
              Protocol: fcp
               OS Type: vmware
Portset Binding Igroup: fc_pset_1
           Igroup UUID: c817c090-06dd-11ea-ab7c-xxxxxxxxxx
                  ALUA: true
            Initiators: 21:00:00:24:ff (ESX01) (not logged in)

 

 

 

lun show -m
Vserver    Path                                      Igroup   LUN ID  Protocol
---------- ----------------------------------------  -------  ------  --------
svm_fc 
           /vol/lun_test_01_vol/lun_test_01          IGROUP_ESX  50  fcp

-> OS Type : vmware
::> vol show -instance        
Vserver   Volume       Aggregate    State      Type       Size  Available Used%
--------- ------------ ------------ ---------- ---- ---------- ---------- -----
svm_fc 
          lun_test_01_vol 
                       NODE_01_SSD_1 
                                    online     RW      330.7GB    29.46GB   91%

 

 

Thank you,

 

 

 

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Huh.  Your ports need to be in FC mode, not cna.       Are there FC SFPs in there? 

give this a read through how to convert:   

https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.dot-cm-sanag%2FGUID-E2CD31BE-28EC-468E-AF49-83A641575799.html

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Ah sory I take the wrong copy/paste.

Yes the convert operation are good make and nose rebooted (even if I don’t see fabric characteristics and topology).

 

For sure I launch the command tomorrow.

 

Do you know how works the fcp ping command ? I don’t see result on docs for the explanation of results. 

 

Thanks.

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Ok if I good understand :

- ping igroup : I must specify in WWPN the LIF

 

- ping initiator : I must specify in WWPN vmware

do you think it’s « technically » working if I specify the WWPN of Fabric Switch ?

 

if I have « zone-info-not-available » it seems netapp correctly go until the switch and after zoning it’s not good ? That’s seems good configured in AFF side ?

 

thank you ,

Re: ONTAP 9.6 FC issue with vmware HBA don't see NetApp

Hello,

 

I check on AFF ucadmin are fine :

::> ucadmin show
                       Current  Current    Pending  Pending    Admin
Node          Adapter  Mode     Type       Mode     Type       Status
------------  -------  -------  ---------  -------  ---------  -----------
NODE-01   0c       fc       target     -        -          online
NODE-02   0c       fc       target     -        -          online
Forums