FAS and V-Series Storage Systems Discussions

Shelf ID showing as 204 (instead of the assigned 12).

Hello, 

 

I just recently had NetApp Support replace a damaged IOM for the B side on a 224C disk shelf and after plugging in cables, one of the nodes (on a 2 node cluster) shows a shelf ID of 204 (when it's supposed to be 12). Anyone seen this before? System is cabled correctly physically and only 1 nodes shows it incorrect, not the other. Config Advisor came back clean and 'sysconfig' shows Multi-Path HA for both nodes. Very weird. 

 

As shown on the incorrect node...

Expanders on channel 0d:
Level 1: WWN 500a09800746cd21, ID 14, Serial Number ' SHFGD1644000115', Product 'DS22412IOM12A ', Rev '0220', Slot A
Level 2: WWN 500a09800746cac9, ID 13, Serial Number ' SHFGD1644000116', Product 'DS22412IOM12A ', Rev '0220', Slot A
Level 3: WWN 500a0980074567cd, ID 12, Serial Number ' SHFGD1644000117', Product 'DS22412IOM12A ', Rev '0220', Slot A

 

Expanders on channel 2c: (notice the slot is A on the shelf in question, when it should be B)
Level 1: WWN 500a0980082e28b5, ID 204, Serial Number ' 0020B8A2', Product 'DS22412IOM12A ', Rev '0220', Slot A
Level 2: WWN 500a09800746c64d, ID 13, Serial Number ' SHFGD1644000116', Product 'DS22412IOM12A ', Rev '0220', Slot B
Level 3: WWN 500a0980082e292d, ID 14, Serial Number ' SHFGD1644000115', Product 'DS22412IOM12A ', Rev '0220', Slot B

 

 

As shown on the HA partner...

Expanders on channel 0d:
Level 1: WWN 500a0980082e292d, ID 14, Serial Number ' SHFGD1644000115', Product 'DS22412IOM12A ', Rev '0220', Slot B
Level 2: WWN 500a09800746c64d, ID 13, Serial Number ' SHFGD1644000116', Product 'DS22412IOM12A ', Rev '0220', Slot B
Level 3: WWN 500a0980082e28b5, ID 12, Serial Number ' SHFGD1644000117', Product 'DS22412IOM12A ', Rev '0220', Slot B

 

Expanders on channel 2c:
Level 1: WWN 500a0980074567cd, ID 12, Serial Number ' SHFGD1644000117', Product 'DS22412IOM12A ', Rev '0220', Slot A
Level 2: WWN 500a09800746cac9, ID 13, Serial Number ' SHFGD1644000116', Product 'DS22412IOM12A ', Rev '0220', Slot A
Level 3: WWN 500a09800746cd21, ID 14, Serial Number ' SHFGD1644000115', Product 'DS22412IOM12A ', Rev '0220', Slot A

 

This is a 'run [nodename] storage show disk -p' command on the incorrect node

2c.0020B8A2.0 B 0d.12.0 A 12 0
2c.0020B8A2.1 B 0d.12.1 A 12 1
2c.0020B8A2.2 B 0d.12.2 A 12 2
2c.0020B8A2.3 B 0d.12.3 A 12 3
2c.0020B8A2.4 B 0d.12.4 A 12 4
2c.0020B8A2.5 B 0d.12.5 A 12 5
2c.0020B8A2.6 B 0d.12.6 A 12 6
2c.0020B8A2.7 B 0d.12.7 A 12 7
2c.0020B8A2.8 B 0d.12.8 A 12 8
2c.0020B8A2.9 B 0d.12.9 A 12 9
2c.0020B8A2.10 B 0d.12.10 A 12 10
2c.0020B8A2.11 B 0d.12.11 A 12 11
2c.0020B8A2.12 B 0d.12.12 A 12 12
2c.0020B8A2.13 B 0d.12.13 A 12 13
2c.0020B8A2.14 B 0d.12.14 A 12 14
2c.0020B8A2.15 B 0d.12.15 A 12 15
2c.0020B8A2.16 B 0d.12.16 A 12 16
2c.0020B8A2.17 B 0d.12.17 A 12 17
2c.0020B8A2.18 B 0d.12.18 A 12 18
2c.0020B8A2.19 B 0d.12.19 A 12 19
2c.0020B8A2.20 B 0d.12.20 A 12 20
2c.0020B8A2.21 B 0d.12.21 A 12 21
2c.0020B8A2.22 B 0d.12.22 A 12 22
2c.0020B8A2.23 B 0d.12.23 A 12 23

This is the same command on the HA partner.

2c.12.0 A 0d.12.0 B 12 0
2c.12.1 A 0d.12.1 B 12 1
2c.12.2 A 0d.12.2 B 12 2
2c.12.3 A 0d.12.3 B 12 3
2c.12.4 A 0d.12.4 B 12 4
2c.12.5 A 0d.12.5 B 12 5
2c.12.6 A 0d.12.6 B 12 6
2c.12.7 A 0d.12.7 B 12 7
2c.12.8 A 0d.12.8 B 12 8
2c.12.9 A 0d.12.9 B 12 9
2c.12.10 A 0d.12.10 B 12 10
2c.12.11 A 0d.12.11 B 12 11
2c.12.12 A 0d.12.12 B 12 12
2c.12.13 A 0d.12.13 B 12 13
2c.12.14 A 0d.12.14 B 12 14
2c.12.15 A 0d.12.15 B 12 15
2c.12.16 A 0d.12.16 B 12 16
2c.12.17 A 0d.12.17 B 12 17
2c.12.18 A 0d.12.18 B 12 18
2c.12.19 A 0d.12.19 B 12 19
2c.12.20 A 0d.12.20 B 12 20
2c.12.21 A 0d.12.21 B 12 21
2c.12.22 A 0d.12.22 B 12 22
2c.12.23 A 0d.12.23 B 12 23

 

 

 

5 REPLIES 5

Re: Shelf ID showing as 204 (instead of the assigned 12).

I have seen some odd stuff with shelves before.  But what's support say?  Have they had to try to re-seat the IOM or do a take-over?    How's the firmware look?  is it current or stuck updating? 

Re: Shelf ID showing as 204 (instead of the assigned 12).

That's bizarre. I wonder if something else is still wrong. Definitely have our HW folks look. From my initial glance I don't know why this would happen but something is definitely off.

 

If it's just cosmetic it should function just fine.

Re: Shelf ID showing as 204 (instead of the assigned 12).

Re: Shelf ID showing as 204 (instead of the assigned 12).

Thanks for all the insight! I have tried reseating the IOM, but only for about 10 seconds. Have not done a takeover/giveback. I would need to schedule an MX for that since we have customer data on that array. 

Highlighted

Re: Shelf ID showing as 204 (instead of the assigned 12).

I would also verify with support.   They have had me to do takeover/givebacks as part of troubleshooting quirky shelf issues. 

 

Forums