FAS and V-Series Storage Systems Discussions

Highlighted

Unable to SSH while telnet.enable is off

Filer setting as below:

asihkgfp00n1> options ssh
ssh.access                   *
ssh.enable                   on
ssh.idle.timeout             0
ssh.passwd_auth.enable       on
ssh.port                     22
ssh.pubkey_auth.enable       on
ssh1.enable                  off
ssh2.enable                  on
asihkgfp00n1> options telnet
telnet.access                legacy     (same value required in local+partner)
telnet.distinct.enable       off        (same value required in local+partner)
telnet.enable                on         (same value required in local+partner)

Once telnet.enable is turned off, ssh failed accordingly. Anybody knows why?

The filer is FAS3140, ONTAP 7.3.1P2.

Regards,

Terrence

3 REPLIES 3
Highlighted

Re: Unable to SSH while telnet.enable is off

Hi, I had the exact same thing. It is described in BUG ID 344484.

However this should be fixed in 7.3.1.1P2 (it did for me anyway).

Bjorn

View solution in original post

Re: Unable to SSH while telnet.enable is off

Yes, this is apparently a known issue and we ran into it as well.

Prior to being able to schedule an upgrade to a fixed version, I worked around this by leaving telnet enabled but denying access via telnet to all hosts:

filer> options telnet.access "host=-"

Hope that is useful.

Highlighted

Re: Unable to SSH while telnet.enable is off

Thanks!

Regards,

Terrence Lee

NetApp Global Services

NetApp

852.3605.7700 Main

852.9181.8824 Mobile Phone

terrence.lee@netapp.com

Learn how: netapp.com/guarantee

Check out the KB!
NetApp Insights To Action
All Community Forums