FAS and V-Series Storage Systems Discussions

Highlighted

netapp 2220 doesn't boot - loader-a

hi all

there was a power outage in our building so netapp was poweroff and on again.

as a result, the netapp doesn't boot.

i try to connect to the netapp with comsole cable and i get LOADER-A command.

i tryied to boot_ontap and it doesn't help, that's what i get:

 

LOADER-A> boot_ontap
Loading X86_64/freebsd/image1/kernel:0x100000/8450424 0x90f178/1278800 Entry at 0x801585d0
Loading X86_64/freebsd/image1/platform.ko:0xa48000/653264 0xb8d8e8/692592 0xae77 e0/39304 0xc36a58/42192 0xaf1168/86252 0xb06254/63752 0xb15b60/140448 0xc40f28/1 58856 0xb38000/2016 0xc67bb0/6048 0xb387e0/304 0xc69350/912 0xb38910/1680 0xc696 e0/5040 0xb38fa0/960 0xc6aa90/2880 0xb39360/184 0xc6b5d0/552 0xb39420/448 0xb64d e0/12918 0xb8d7f8/237 0xb68058/83952 0xb7c848/69552
Starting program at 0x801585d0
NetApp Data ONTAP 8.1.2 7-Mode

PANIC : The 0 is not a supported platform

version: 8.1.2: Tue Oct 30 19:56:51 PDT 2012
conf : x86_64
cpuid = 0
Uptime: 1s

The operating system has halted.
Please press any key to reboot.

System halting...
cpu_reset called on cpu#0

Phoenix SecureCore(tm) Server
Copyright 1985-2008 Phoenix Technologies Ltd.
All Rights Reserved
BIOS version: 8.1.0
Portions Copyright (c) 2008-2011 NetApp, Inc. All Rights Reserved

CPU = 1 Processors Detected, Cores per Processor = 2
Intel(R) Xeon(R) CPU C3528 @ 1.73GHz
Testing RAM
512MB RAM tested
6144MB RAM installed
256 KB L2 Cache per Processor Core
4096K L3 Cache Detected
System BIOS shadowed
USB 2.0: MICRON eUSB DISK
BIOS is scanning PCI Option ROMs, this may take a few seconds...
WARNING
02A1: SP Not Found
ERROR
No Response to Controller FRU ID Read Request via IPMI
ERROR
No Response to Midplane FRU ID Read Request via IPMI


Boot Loader version 4.1
Copyright (C) 2000-2003 Broadcom Corporation.
Portions Copyright (C) 2002-2011 NetApp

CPU Type: Intel(R) Xeon(R) CPU C3528 @ 1.73GHz
BIOS POST Failure(s) detected. Abort AUTOBOOT

 

 

 

please anyone can help?

thanks

14 REPLIES 14
Highlighted

Re: netapp 2220 doesn't boot - loader-a

It's almost certainly hardware issue. You need to open case to get it replaced.

Highlighted

Re: netapp 2220 doesn't boot - loader-a

how can i confirm that it's hardware issue before i open a case?

Highlighted

Re: netapp 2220 doesn't boot - loader-a

That's exactly the reason to open the case - so support can investigate it.

Highlighted

Re: netapp 2220 doesn't boot - loader-a

What was the issue? and how did you resolve this issue?


@orennaf wrote:

hi all

there was a power outage in our building so netapp was poweroff and on again.

as a result, the netapp doesn't boot.

i try to connect to the netapp with comsole cable and i get LOADER-A command.

i tryied to boot_ontap and it doesn't help, that's what i get:

 

LOADER-A> boot_ontap
Loading X86_64/freebsd/image1/kernel:0x100000/8450424 0x90f178/1278800 Entry at 0x801585d0
Loading X86_64/freebsd/image1/platform.ko:0xa48000/653264 0xb8d8e8/692592 0xae77 e0/39304 0xc36a58/42192 0xaf1168/86252 0xb06254/63752 0xb15b60/140448 0xc40f28/1 58856 0xb38000/2016 0xc67bb0/6048 0xb387e0/304 0xc69350/912 0xb38910/1680 0xc696 e0/5040 0xb38fa0/960 0xc6aa90/2880 0xb39360/184 0xc6b5d0/552 0xb39420/448 0xb64d e0/12918 0xb8d7f8/237 0xb68058/83952 0xb7c848/69552
Starting program at 0x801585d0
NetApp Data ONTAP 8.1.2 7-Mode

PANIC : The 0 is not a supported platform

version: 8.1.2: Tue Oct 30 19:56:51 PDT 2012
conf : x86_64
cpuid = 0
Uptime: 1s

The operating system has halted.
Please press any key to reboot.

System halting...
cpu_reset called on cpu#0

Phoenix SecureCore(tm) Server
Copyright 1985-2008 Phoenix Technologies Ltd.
All Rights Reserved
BIOS version: 8.1.0
Portions Copyright (c) 2008-2011 NetApp, Inc. All Rights Reserved

CPU = 1 Processors Detected, Cores per Processor = 2
@Intel(R) Xeon(R) CPU C3528 @ 1.73GHz
Testing RAM
512MB RAM tested
6144MB RAM installed
256 KB L2 Cache per Processor Core
4096K L3 Cache Detected
System BIOS shadowed
USB 2.0: MICRON eUSB DISK
BIOS is scanning PCI Option ROMs, this may take a few seconds...
WARNING
02A1: SP Not Found
ERROR
No Response to Controller FRU ID Read Request via IPMI
ERROR
No Response to Midplane FRU ID Read Request via IPMI


Boot Loader version 4.1
Copyright (C) 2000-2003 Broadcom Corporation.
Portions Copyright (C) 2002-2011 NetApp

@CPU Type: Intel(R) Xeon(R) CPU C3528 @ 1.73GHz
BIOS POST Failure(s) detected. Abort AUTOBOOT

 

 

 

please anyone can help?

thanks


 

Highlighted

Re: netapp 2220 doesn't boot - loader-a

Hi,

 

we have the same issue after a planned system halt. Unfortunatelly our Contract Services Expired, so we can't open a case.

 

So, the question is the issue was hardwer error related or something other.

Highlighted

Re: netapp 2220 doesn't boot - loader-a

It looks to be an issue with the service processor. I would console onto the SP and see if there are any errrors.

Highlighted

Re: netapp 2220 doesn't boot - loader-a

Can you explain in detail how to connect to SP by console while SP does not detected by controller ??
I have almost same issue with 2240 controller.


Re: netapp 2220 doesn't boot - loader-a

While connected to console, press "Ctrl-G" to switch to the SP console.  "Ctrl-D" to return to the ONTAP/LOADER console.

Highlighted

Re: netapp 2220 doesn't boot - loader-a

Try reseating the controller - physically pull it out and put it back in, but the chance it will fix it is low.

 

Our suggested resolution is to replace the controller.

Highlighted

Re: netapp 2220 doesn't boot - loader-a

Hey,

 

You'll have the SSH directly to the IP of the SP. As the node's not booting, you'll be able to find the IP of the SP in the sysconfig -a in an autosupport.

 

How do you know that the SP isn't be detected by the controller? Is it not responding to pings? Is it timing out when actually physically connected to the management port?

 

Matt

Highlighted

Re: netapp 2220 doesn't boot - loader-a

CTRL+G not working on "problem" node (

Highlighted

Re: netapp 2220 doesn't boot - loader-a

This is not SSH - it`s COM console connection through COM-IP extender.

Node don`t boot in any way i have tried.

sp don`t respond to anything, for example:
LOADER-A> sp status
Communication with SP has timed out.
*** command status = -1
LOADER-A>

 

LOADER-A> sp setup
Error talking to the Service Processor
*** command status = -1
LOADER-A>

Highlighted

Re: netapp 2220 doesn't boot - loader-a

Tried allready - no effort.

Is any way to force reset/reflash SP?

Or at least read the event log from the hang SP ? Allmost any action is acceptable at this moment.

 

The problem with replacing the controller is that the system is not on support and there is no chance that it will be put on support.
Even if I find a used controller somewhere, there will be a question about license transfer.
In general, that a headache (

Highlighted

Re: netapp 2220 doesn't boot - loader-a

I'm not sure what your statement "Tried allready - no effort." was referring to...

 

Similar to Alex's comment, I would simplify the test.

 

If HA, pull the partner node (assuming it's not serving data - take downtime). Leave it out.

Pull the problem PCM out. Leave it out.

Shut off/disconnect the PSUs to the chassis.  Leave them off for at least 1 minute.

Power up the PSU's.

With the console port connected, insert the problem PCM (remember, the HA partner PCM should still be removed).

Check console output.  Wait about a minute - the try "sp status" from LOADER to see if the SP is responsive.

Try Ctrl-G to switch over the SP to see if it's responsive.

If SP remains unresponsive, the PCM would need to be replaced.

Check out the KB!
Knowledge Base
All Community Forums