INSIGHT General Discussion

Highlighted

NetApp Harvest Failed to normalize unit

Hello All,

 

In order to be able to solve problems of data transfer with Dataontap 8.2.5, I installed a new grafana.

I have the latest versions of graphite and Grafana 5.2.4 and NetApp Manager 1.4.1.

 

ISSUE :

Under grafana I have feedback information but my logs go back many warnings like :

 

[2018-09-25 10:52:05] [WARNING] Failed to normalize unit val=[257067423] unit=[wafl_block]
[2018-09-25 10:52:05] [WARNING] Failed to normalize unit val=[823418] unit=[wafl_block]
[2018-09-25 10:53:04] [WARNING] Failed to normalize unit val=[66006654] unit=[wafl_block]
[2018-09-25 10:53:04] [WARNING] Failed to normalize unit val=[85081396] unit=[wafl_block]
[2018-09-25 10:53:04] [WARNING] Failed to normalize unit val=[823428] unit=[wafl_block]
[2018-09-25 10:53:04] [WARNING] Failed to normalize unit val=[257067425] unit=[wafl_block]
[2018-09-25 10:54:04] [WARNING] Failed to normalize unit val=[85081396] unit=[wafl_block]

 

I have arround 40 warning messages by Controler

 

Do you have an idea ?

 

Many thanks

Raphael.

 

5 REPLIES 5
Highlighted

Re: NetApp Harvest Failed to normalize unit

Hi Raphael,

 

I looked at Harvest code and this message shouldn't happen, as "wafl_block" is a unit that should be taken care of.

 

Do you have "normalized_xfer" parameter in the harvest config file?

 

Are you absolutely sure this isn't an old version of Harvest?

Highlighted

Re: NetApp Harvest Failed to normalize unit

Hi

 

Thanks you for your reply.

Yes, i have "normalized_xfer = gb_per_sec" in netapp-harvest.conf

Yes sure, this isn't an old version of Harvest .. 😞

 

Regards

Highlighted

Re: NetApp Harvest Failed to normalize unit

It could be a bug indeed.

 

If you switch to mb_per_sec it should be fine.

 

You can also patch netapp-worker and add on line 2606 :

 

return ($val * 0.000003814697266) if ($connection{normalized_xfer} eq 'gb_per_sec');

View solution in original post

Highlighted

Re: NetApp Harvest Failed to normalize unit

Hi,

 

Thanks you very much !!

My issue is solved.

 

Regards

Highlighted

Re: NetApp Harvest Failed to normalize unit

For anyone else observing the same issue: I will post a patch that will fix this (as well as one other) bug in your Harvest installation. Hopefully by tomorrow 🙂

Check out the KB!
Knowledge Base
All Community Forums